LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   slackware sound problems (http://www.linuxquestions.org/questions/linux-general-1/slackware-sound-problems-18251/)

cerberus 04-11-2002 12:34 AM

slackware sound problems
 
well when i try and play a song in xmms the song just freezes and doesnt play at all it just stays at 0 seconds

please help

Aussie 04-11-2002 02:40 AM

Can you hear anything else?

jamaso 04-11-2002 08:58 AM

are you using gnome ?
 
it happend to me the same thing when running gnome , i tried it on KDE and it worked ok .

hanzerik 04-11-2002 03:21 PM

Take a look at this thread:

http://www.linuxquestions.org/questi...lackware+sound

cerberus 04-11-2002 05:08 PM

no aussie
 
i can hear nothing out of it... and its not my speakers cus its fine on windows so.... i dunno what it can be ive tryed quite abit of stuff any other suggiestions?

cerberus 04-11-2002 05:09 PM

and i always use kde

Aussie 04-11-2002 07:28 PM

Ok cerberus, tell me what sort of sound card you have.

cerberus 04-12-2002 12:43 AM

soniq 5330 i think

Aussie 04-12-2002 12:54 AM

Quote:

Originally posted by cerberus
soniq 5330 i think
Do "lspci" and post the part about your sound controller for me to look at, it should be something like this,
bash-2.05$ su
Password:
bash-2.05# lspci
00:00.0 Host bridge: VIA Technologies, Inc.: Unknown device 0305 (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc.: Unknown device 8305
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586 IDE [Apollo] (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:09.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV11 (rev b2)
bash-2.05#
The bold line is the one I'm interested in.

cerberus 04-12-2002 09:37 PM

sorry i was so late fixed my connection
 
00:00.0 Host bridge: Intel Corporation: Unknown device 1a30 (rev 03)
00:01.0 PCI bridge: Intel Corporation: Unknown device 1a31 (rev 03)
00:1e.0 PCI bridge: Intel Corporation: Unknown device 244e (rev 12)
00:1f.0 ISA bridge: Intel Corporation: Unknown device 2440 (rev 12)
00:1f.1 IDE interface: Intel Corporation: Unknown device 244b (rev 12)
00:1f.2 USB Controller: Intel Corporation: Unknown device 2442 (rev 12)
00:1f.3 SMBus: Intel Corporation: Unknown device 2443 (rev 12)
00:1f.4 USB Controller: Intel Corporation: Unknown device 2444 (rev 12)
01:00.0 VGA compatible controller: nVidia Corporation Vanta [NV6] (rev 15)
02:01.0 Communication controller: CONEXANT: Unknown device 1066 (rev 08)
02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
02:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 03)

Aussie 04-12-2002 11:15 PM

Ok, you need to do "modprobe es1371" as root to load the module for your sound card. You can check it loaded with "lsmod", once that's done you should have sound but if not then check the permissions on /dev/dsp*, /dev/mixer* and /dev/sequencer*. To have the es1371 module load at boot, uncomment the line (remove the #) /sbin/modprobe es1371 in /etc/rc.d/rc.modules.

cerberus 04-12-2002 11:30 PM

what am i suppost to check for in /dev/dsp and /dev/mixer?
 
????

cerberus 04-12-2002 11:44 PM

nevermind
 
the permissions seam to be right i have a ensoniq ES1371 i think its something with the card not being capatible with slackware

taz.devil 04-12-2002 11:45 PM

the common devices you need to look for are:

dsp
dsp1
mixer
mixer1
audio
audio1
sequencer
sequencer2
midi00-03

cerberus 04-13-2002 12:07 AM

they all have the same permissions


read write

user x x

group x x


All times are GMT -5. The time now is 06:20 PM.