LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-11-2003, 09:36 AM   #1
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Rep: Reputation: 0
Keyboard and mouse stops working after changing XConfig


I recently installed Redhat Linux 9.0 in my windows system (with dual booting). It worked fine initially, but then I tried to change the mouse setting from 2-button PS/2 to wheel mouse PS/2. After this, on rebooting, the linux shuts down my keyboard and mouse the moment Xwindows starts. The keyboard and mouse, however works fine in windows, and even works in linux till the point xwindows starts.

Last edited by greensleeves_2K; 11-13-2003 at 11:51 PM.
 
Old 11-11-2003, 12:21 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
On the boot loader prompt, type the
name of your kernel boot image,
append the word single

Then as root go to
/etc/X11
Edit the file (using pico, mc, vi, emacs,
whichever you know best)

XF86Config

Find a line that says
Option "Protocol" "PS/2"
Change that to
Option "Protocol" "IMPS/2"

Cheers,
Tink
 
Old 11-12-2003, 09:14 AM   #3
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for the prompt reply.
I checked the XF86Config file. The mouse setting is already at IMPS/2. Should I try changing it to PS/2? Could anything else be wrong with the XF86Config file?
 
Old 11-12-2003, 12:12 PM   #4
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
I just tried changing IMPS/2 to PS/2, but that did not work. Can somebody tell me what is wrong with my XF86Config file, and how to solve the problem? I am copy pasting the file for reference:



# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "DDCPROBED"
DisplaySize 280 210
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "trident"
VendorName "Videocard vendor"
BoardName "Trident CyberBlade (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection






I would be grateful if anyone could sugest a solutino for my problem.

Regards
greensleeves
 
Old 11-12-2003, 02:48 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Do you have both a PS/2 and a USB
mouse or something? :)

Is your keyboard USB or PS/2?

Cheers,
Tink
 
Old 11-12-2003, 10:54 PM   #6
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
I have a PS/2 keyboard and a wheel mouse with PS/2 port. Both these were detected correctly by linux during installation and were working fine till I changed the default settings for mouse from PS/2 to wheel mouse PS/2 (this I did in my XWindows by going to Systems settings). I made no changes to the keyboard settings. After this, on rebooting, both the keyboard and mouse stopped working the moment XWindows started. This problem has persisted since then.
 
Old 11-14-2003, 09:14 AM   #7
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
I am still unable to solve my problem. Can somebody detect the problem with the XF86Config file given above? Otherwise I can't use my linux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vt: kernel panic during shutdown from atkbd.c -Wireless keyboard-mouse teddymills Linux - Hardware 0 11-28-2005 12:51 PM
Keyboard & Mouse Not Working At Login With Linux-Mandrake 6.5 Rafiki Linux - Software 7 06-04-2005 10:07 PM
user login: no keyboard access (mouse OK) - no problem under root guillaume31 Mandriva 2 07-20-2004 12:24 PM
No USB Mouse or USB Keyboard after Shutdown ooliquidice Linux - Hardware 3 10-09-2003 02:05 PM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration