LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-04-2005, 08:40 AM   #1
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 453

Rep: Reputation: 30
Question setting up an autoresponder


Hello,
I want to set up an auto responder. For example when a user goes in vacation I want an autoresponder to send an email to the sender with this information.
How can I do this quickly?

I use sendmail as the mail server.


Thanks,
ddaas
 
Old 02-07-2005, 07:03 AM   #2
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 453

Original Poster
Rep: Reputation: 30
I found out that I can do that with vacation program.
So, I installed vacation-1.2.6.1-3.i386.rpm, created ~/.vacation.msg with the fallowing content:

Subject: away from my mail

I will not be reading my mail for a while.
Your mail concerning "$SUBJECT"
will be read when I'm back.


Then I created ~/.forward:
\username_who_is_in_vacation, "|/usr/bin/vacation username_who_is_in vacation"



I ran: #/usr/bin/vacation -I


Despite all these, it doesn't work.

I'am using sendmail V8.12.

Do you know why? What can I do?


thanks,
ddaas
 
Old 02-07-2005, 08:10 AM   #3
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,910

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
I think that you must include as first line in your vacation message a "From: yourname@yourdomain.com"
Also take a look at your mail logs to see if you find the reason that vacation does not work.
 
Old 02-09-2005, 03:02 AM   #4
ddaas
Member
 
Registered: Oct 2004
Location: Romania
Distribution: Ubuntu server, FreeBsd
Posts: 453

Original Poster
Rep: Reputation: 30
the problem was that I use an alias. The ~/.forward file had to have the following line: \username, "|/usr/bin/vacation -a alias@yourdomain.com username"

Now, everything works just fine.


ddaas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting the xrandr setting permanently dazdaz Linux - Hardware 2 11-24-2005 01:57 AM
Setting up a new HD Gomi Linux - Newbie 16 08-26-2004 02:35 PM
Setting unusual networking setting in Mandrake zamri Linux - Networking 1 05-28-2004 06:43 AM
setting up x giddleberry Slackware 8 10-09-2003 10:48 AM
what are the setting ?? johnyy Linux - Software 4 09-25-2003 02:51 AM


All times are GMT -5. The time now is 06:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration