LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   setting framebuffer (vga mode) after booting (http://www.linuxquestions.org/questions/linux-general-1/setting-framebuffer-vga-mode-after-booting-687347/)

zoombee 11-30-2008 10:13 PM

setting framebuffer (vga mode) after booting
 
At boot time, in grub configuration file (/boot/grub/menu.lst), if I place "vga=788" inside "root /boot/vmlinuz..", then my Slax starts in 800x600 instead of 640x480. But if I start in 640x480, can I change the vga mode after Slax has started? (i.e. after I see the login prompt).

thanks

rylan76 12-01-2008 02:13 AM

Not sure what you mean - are you starting up in text mode?

Once you have logged in in textmode, you can usually do

Code:

# startx
I. e. type startx in the terminal to get into graphical mode.

Otherwise, there should be a file called /etc/inittab where you can set the system to boot directly into graphical mode:

Code:

#
# inittab      This file describes how the INIT process should set up
#              the system in a certain run-level.
#
# Author:      Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#              Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
#  0 - halt (Do NOT set initdefault to this)
#  1 - Single user mode
#  2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#  3 - Full multiuser mode
#  4 - unused
#  5 - X11
#  6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly. 
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:once:/etc/X11/prefdm -nodaemon

Change the line

Code:

id:3:initdefault:
which is what you SHOULD have if you are starting up in text mode, to

Code:

id:5:initdefault:
i. e. change the 3 to a 5 - if you save the config file and reboot, the system should come up directly in XWindows on start.

I hope I understood what you meant... most distros these days if installed default -automatically- install to runlevel 5, i. e. start XWindows on boot?

Note that your message is ambiguous - if you literally meant the VGA Framebuffer function (i. e. you ARE in graphical mode on boot, but NOT in X, on your terminal) - that usually can also be configured as a kernel compile-time option?

zoombee 12-04-2008 05:41 PM

Oh sorry, indeed it was ambigous. I start Slax in text mode (I do not use X Windows). I think starting with VGA=normal, it will use 640x480, and that makes 80x40 characters. Starting with VGA=791 makes it use 1024x768 so it will fit 132x64 characters. It just fits more on your screen (for example when you use MC that can be very usefull)


All times are GMT -5. The time now is 11:08 AM.