LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Set shell resolution (http://www.linuxquestions.org/questions/linux-general-1/set-shell-resolution-430610/)

huwnet 04-01-2006 08:46 AM

Set shell resolution
 
Is there any way to change the resolution of my shell from 800 x 600 to 1280 x 1024?

I am using bash and Gentoo 2006.0

Thanks

SciYro 04-01-2006 08:51 AM

resolution in what? The framebuffer? or X?

edit: for X, use "xrandr", for the framebuffer, im not sure, but "fbset" is where i would start looking

mikshaw 04-01-2006 09:02 AM

for console you can probably change your bootloader's config to send one of these parameters...

256 colors: vga=775 or vga=0x307
32k colors: vga=793 or vga=0x319
64k colors: vga=794 or vga=0x31A
16M colors: vga=795 or vga=0x31B

huwnet 04-01-2006 09:27 AM

Quote:

Originally Posted by mikshaw
for console you can probably change your bootloader's config to send one of these parameters...

256 colors: vga=775 or vga=0x307
32k colors: vga=793 or vga=0x319
64k colors: vga=794 or vga=0x31A
16M colors: vga=795 or vga=0x31B

Thanks

Also is there anyway to change the shell keyboard layout to gb?

huwnet 04-15-2006 01:09 PM

Quote:

Originally Posted by huwnet
Also is there anyway to change the shell keyboard layout to gb?

Is this possible or is this something that only applies in X?

pastoreerrante 05-17-2010 09:52 AM

Hi all,

I have exactly this problem with debian lenny. I have no X server, and the vga=791 option in menu.lst doesn't work for me.

When I boot with that option, Grub says to me that the maximum resolution supported is 80x90 or something similar.

So does anyone know how to change shell resolution to 1280x1024?

Thank you,

Daniele

Update: I ran the command hwinfo --framebuffer in order to see the resolution my screen supports and, between others, I can see the following:

Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits

Every time I put one of this hexadecimal values in the "vga= " option in menu.lst, after the reboot, I receive the "Undefined Video Mode Number error message", basically saying me that I'm limited to the text modes resolutions (maximum is 80x60).

I don't understand where the problem is...

Update: Problem Fixed

The reason was that the nvidia framebuffer support is not enabled by default on debian lenny. So the solution was a kernel recompilation enabling that feature (Device Driver > Graphic Card > Framebuffer Support > Nvdia Framebuffer)

After this, my console is 1280x1024:
####################################################
daniele@daniele:~$ fbset

mode "1280x1024-60"
# D: 91.000 MHz, H: 63.195 kHz, V: 59.957 Hz
geometry 1280 1024 1280 25766 8
timings 10989 80 48 3 20 32 7
hsync high
accel true
rgba 8/0,8/0,8/0,0/0
endmode
####################################################

There was no need to edit menu.lst with vga=79x options! the best resolution was set automatically :-)


All times are GMT -5. The time now is 03:52 PM.