LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-08-2001, 03:12 PM   #1
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 468

Rep: Reputation: 30
Angry


I am using SuSE 6.4.
I am not sure what I did, but the KDE or Xsession for any user other than root is disabled. When I try to log in as a different user it says "Xsession: login for user <username> is disabled".
Does anyone know how to set the enable flag back again?
TIA for any leads,
 
Old 06-09-2001, 02:57 AM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Quote:
Originally posted by concoran
I am using SuSE 6.4.
I am not sure what I did, but the KDE or Xsession for any user other than root is disabled. When I try to log in as a different user it says "Xsession: login for user <username> is disabled".
Does anyone know how to set the enable flag back again?
TIA for any leads,
Are you starting KDE with 'startx'? Did you change any 'defualt windowmanger' settings in YaST?
 
Old 06-10-2001, 05:12 AM   #3
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 468

Original Poster
Rep: Reputation: 30
Unhappy No, I havn't made any changes

Hi McLoed, Good to see you again,
I don't start KDE using 'startx', and I havn't made any changes to default WindowManager either. Everything was just fine until one day when SuSE disabled xsessio (KDE) login for any user other than root.

BTW, I tried 'init 2', and then logged in as a user1, and ran 'startx'. The KDE started for that user.

I also went to susewm in YaST, but was not able to figure out how to disable / enable xsession for users.

TIA for any help..
 
Old 06-10-2001, 02:07 PM   #4
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Did you make any changes with the KDE user manager?
 
Old 06-12-2001, 04:44 AM   #5
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 468

Original Poster
Rep: Reputation: 30
Not that I know of

No, I haven't made any changes to KDE. Only one thing I did was to set the default window for user1 to be WindowMaker, which I later reset back to KDE. Other than that, I haven't made any changes.
I am a newbie, I just keep going to YaST and other setup tools, utilities and see what all they do, without changing any settings..
Thanks,
 
Old 10-02-2001, 08:11 AM   #6
ricochez
LQ Newbie
 
Registered: Oct 2001
Location: Düsseldorf, Germany
Distribution: Suse 6.4 , 7.1
Posts: 1

Rep: Reputation: 0
Hi folks,

after a lot of searching I finally found the solution to this "stupid" problem which worked for me ( Suse 6.4 ).

When a user tries to login to the machine via xdm a script called Xsession ( dir should be something like /usr/X11R6/lib/X11/xdm ) is executed, which contains a block of code like

#
# Disable graphical login if normal login is disabled
#
login=false
while read sh ; do
if test "$sh" = "$SHELL" ; then
login=true
break
fi
done < /etc/shells

The problem occurs when the administrator creates a user account with the wrong shell or let us say a missing shell. Imagine you create a user called scott and with a default shell /usr/ksh. If you take a clooser look on /usr/ksh you will find out that this is only a link which points to /usr/bin/ksh. Now check the /etc/shells which may look like this:

/bin/ash
/bin/bash
/bin/bash1
/bin/csh
/bin/false
/bin/sh
/bin/tcsh
/bin/true
/usr/bin/csh
/usr/bin/ksh
/usr/bin/passwd
/usr/bin/rbash
/usr/bin/tcs
/usr/bin/zsh

If you put these values into the Xsession script you will see by whom all the trouble is caused by. Based on the fact that no /bin/ksh entry is included in the /etc/shells ( as the true ksh is in /usr/bin/ and in /bin there´s only a symbolic link) the situation goes beserk as the variable login is still false after all and the user get the beloved message ;-)

So simply modify your user accounts to a shell which is being listed in /etc/shells or try to add the missing entry in /etc/shells like /bin/ksh and try again.

Cu

Ulrich

Last edited by ricochez; 10-02-2001 at 08:15 AM.
 
Old 11-19-2001, 10:06 PM   #7
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 468

Original Poster
Rep: Reputation: 30
Sounds great Ulrich. Thx for insightful info.

However, It's been long since I got rid of that installation due to my inability to solve the problem, and now I have a new setup.

Thanks again,
Ravi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 9.2: Recompile php with --enable-session frisco-driver Suse/Novell 1 10-24-2005 05:14 AM
xfce4-session fails to save session ! OneManArmy Debian 0 12-10-2004 02:14 PM
Enable session on PHP 4.4.3 robertoneto123 Linux - Newbie 1 04-13-2004 01:45 PM
repeat key disabled. how to enable it again? neon Linux - Newbie 0 11-20-2003 07:47 PM
add a session to Session of gdm freenet Linux - Software 0 08-07-2003 05:21 AM


All times are GMT -5. The time now is 06:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration