LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-28-2010, 05:16 PM   #1
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Rep: Reputation: 33
sendmail takes 30 second to send.


Hi group,
I am having a problem with sendmail. Using a php script the process that 30 seconds to send. I have googled the symptoms and have changed sendmail.cf ==> Timeout.ident=0 and configured /etc/hosts properly.

I'm using Fedora 11 and 12, same issue.

Anything else I need to fix??
 
Old 08-28-2010, 08:57 PM   #2
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
[Solved] sendmail takes 30 second to send.

Quote:
Originally Posted by MrUmunhum View Post
Hi group,
I am having a problem with sendmail. Using a php script the process that 30 seconds to send. I have googled the symptoms and have changed sendmail.cf ==> Timeout.ident=0 and configured /etc/hosts properly.

I'm using Fedora 11 and 12, same issue.

Anything else I need to fix??
It turns out that Timeout.ident is in two config files!
Code:
grep Timeout.ident *
sendmail.cf:O Timeout.ident=0s
submit.cf:O Timeout.ident=0s
I really hate that!

All is well now.
 
Old 08-31-2010, 05:23 PM   #3
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
sendmail broken again

After rebooting, sendmail is delaying out going mail again by 40 seconds.
It was fixed before rebooting, it only took less than 1 second.

Any ideas?
 
Old 08-31-2010, 06:28 PM   #4
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by MrUmunhum View Post
After rebooting, sendmail is delaying out going mail again by 40 seconds.
It was fixed before rebooting, it only took less than 1 second.

Any ideas?
I think is has to do with the network changes I made. I redefined the virtual network.
 
Old 09-05-2010, 01:52 PM   #5
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
[Solved] sendmail takes 30 second to send. Again!

I changed the Trusted.users file to add apache and root. Now sendmail takes less than 1 second.
The problem was that the run user changed when I did the 'service sendmail start' from when the system booted. I think??

Last edited by MrUmunhum; 09-05-2010 at 01:54 PM.
 
Old 09-07-2010, 08:16 PM   #6
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
Well it broke again. This time I made changes to the /etc/hosts file, rebooted and now it works again.

Hope all of this is helping other with simular problems?

Last edited by MrUmunhum; 09-07-2010 at 08:17 PM.
 
Old 09-07-2010, 08:40 PM   #7
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
I'm not having that problem - I just wanted to thank you for keeping the thread updated with what happened and how you fixed it
 
Old 09-08-2010, 12:13 AM   #8
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 424

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by gilead View Post
I'm not having that problem - I just wanted to thank you for keeping the thread updated with what happened and how you fixed it
You are more than welcome. I just want to give back to the community.
 
  


Reply

Tags
email, php, sendmail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail takes about 3 minutes to load cizzi Linux - Software 2 02-12-2007 11:13 AM
php mail() takes too long and doesn't send jon23d Linux - Server 2 09-23-2006 06:04 PM
why sendmail takes so long to start? fromzj Linux - Newbie 6 08-13-2002 04:11 PM
sendmail takes too long to come up ... t0dd Linux - Software 1 03-11-2002 02:59 PM
Sendmail takes 5 minutes to start glock19 Linux - General 9 02-01-2002 12:33 PM


All times are GMT -5. The time now is 08:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration