LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Screen Goes Power Save Mode (http://www.linuxquestions.org/questions/linux-general-1/screen-goes-power-save-mode-135970/)

CrAzY G 01-18-2004 07:09 AM

Screen Goes Power Save Mode
 
I have seen this asked elsewhere but its always something slightly different and doesnt help.

Anyway this time i installed Mandrake 9.2 and i did it through the graphic install and all went well.. Everything seems fine. So then i restarted my pc and tried to boot Mandrake. when its about to boot the screen just goes blank (black) and its like gone into power save mode. It cant be a graphics drivers cause i checked them and they are there. Geforce 4ti 4600.

Im begining to think its my screen. I have a Dell UltraSharp 2000FP.

Any ideas?:newbie:

MartinN 01-18-2004 08:41 AM

Hi!

I think that you have set a too high resolution and/or update frequency for your monitor. When the monitor doesn't find a signal it shuts down.

Try editing your /etc/X11/XF86Config file. I'm not very familiar with Mandrake, so I can't tell you how to do it. Someone else can probably tell how to get to a text mode login.

Good luck!
Martin

CrAzY G 01-18-2004 10:44 AM

Okay well i am able to get to the text mode login. How would i edit this file and what do i want it to say?

MartinN 01-18-2004 11:01 AM

Hi again!

Have you got emacs installed? First look at which file you have, since there are two alternatives:
~> cd /etc/X11
~> ls -l

You should have either a file called XF86Config or a file called XF86Config-4.

First make a backup copy the file and then edit it:
~> cp XF86Config XF86Config_old
~> emacs XF86Config

The section "Monitor" should look like this:
Code:

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Dell 2000FP"
        HorizSync    31.5 - 80.0
        VertRefresh  56.0 - 76.0
        ModeLine    "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
        ModeLine    "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
        ModeLine    "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
        ModeLine    "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
        Option      "dpms"
EndSection

Save the file with ctrl-x ctrl-s. Leave emacs with ctrl-x ctrl-c. If you make a mistake, you can leave emacs without saving.

Good luck!
Martin

CrAzY G 01-18-2004 12:53 PM

I feel terrible being a complete newb.. but everyone starts off as one. what is emacs?

And is that what i should see.. or what i should make it say.. ?

MartinN 01-18-2004 02:05 PM

Hi again!

Sorry, if you had posted this in the newbie section I would have given more detailed instructions (hint about how I try to answer questions in different sections ;) ).

Emacs is a text editor, but never mind. Do like this instead.

I made a reply in this thread about getting a file off the Linux computer and on to a floppy, so that you can edit it elsewhere:
http://www.linuxquestions.org/questi...hreadid=131637

Get your /etc/X11/XF86Config (or XF86Config-4, whichever you have) and post it here.

Regards
Martin

CrAzY G 01-18-2004 02:24 PM

Will do.. and i will add i just saw my config file. (apparantly i have both the vonfig and config-4 but it uses config-4.. well thats what it said. so ill post config-4 here in a few minutes.

CrAzY G 01-18-2004 02:52 PM

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Dell"
ModelName "Dell 2000FP (Digital)"
HorizSync 31.5-80.0
VertRefresh 56.0-76.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nv"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 960
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 960
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 960
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 960
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

MartinN 01-18-2004 03:33 PM

I wonder why there are no 'Modes' lines in your file? I thought they were mandatory...

Try editing your 'Display' sections (all of them) from this:
Code:

Subsection "Display"
Depth <whatever value>
Virtual 1280 960
EndSubsection

to this:
Code:

Subsection "Display"
Depth <...
Modes  "640x480" "800x600" "1024x768" "1280x1024"
Virtual 1280 960
EndSubsection

Now, save the file back to where it came from on the Linux computer and start X. You should get to a graphical display in 640*480. Try cycling through the video modes with ctrl-alt-(and the '+' key on the numerical keyboard).

Once you verify that this works, you can put the desired resolution first in the list in the Modes section.

Good luck!
Martin

CrAzY G 01-18-2004 03:34 PM

thanks ill try this now. By the way is there another way i can conatact you. perhaps msn or Aim or even yahoo?

MartinN 01-18-2004 03:38 PM

Only e-mail I'm afraid. If you think that it would be more convenient than writing posts here, please do send an e-mail. Do it by clicking on my 'profile' button.

Regards
Martin


All times are GMT -5. The time now is 01:51 PM.