LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Scim + KDE (slackware/general) (http://www.linuxquestions.org/questions/linux-general-1/scim-kde-slackware-general-303846/)

Dodecha 03-20-2005 07:47 AM

Scim + KDE (slackware/general)
 
Hi, i'm new here to the forum!

Might be rude of me to just start of with a question in my first post. but i've had headaches for days as a result of this problem:

I want japanese input for KDE, i watch alot of anime, and decided to try an learn some japanese!
I have all the fonts required (i can view japanese in browsers, and kiten the japanese learning tool displays all kana and kanji as it's supposed to).

I've installed scim, and i'm using the Wnn engine (scim-anthy didn't compile, so i used this one) Using several howto's and forum threads i set my ~/.xinit to this (my native language beeing norwegian):

Code:

#Scim input mamager related vars
export LC_TYPE="nb_NO"
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim 
/opt/kde/bin/startkde

Started up kde, the skim icon in the tray came, and i configured it to use scim-panel-kde and kconfig..

I got the Wnn immodule listed under japanese in the IM Engine window..

BUT.. i left click the icon, and what comes up is a small menu peice with nothing on it.. okey.. I read that this has to do with a faulty configuration/setup, i then read i need a
qt-immodule patch for qt and recompile that, OR i can install qt-immodule-bc so i don't have to recompile all qt apps for dependencies..

my question to you is: WHERE can i get qt-immodule-bc? everywhere i've looked i only get references to gentoo forums where they all install ot via emerge.
I've never found the qt-immodule patch because i always get sent to some freedesktops.org page which just sends me around in a circle around their site without actually giving me some usefull information OR url's.. The page drives me mad!

So please! pretty please... can someone help a poor guy make this work?

-Regards

liucougar 03-20-2005 10:14 AM

LC_TYPE is wrong
 
export LC_TYPE="nb_NO"
you can not use as your LC_TYPE, at least you should use a UTF-8 one, please consult here:
http://www.scim-im.org/wiki/document...tion_of_system

(the documentation/wiki section is under construction now, and at present the privilege for self-registered user to edit pages is not granted. As soon as the wiki system is finished, everyone can contribute)

Dodecha 03-20-2005 03:28 PM

What LC_TYPE is set to has _nothing_ to do with my current problem.. but thanks, i have set the LC_TYPE to nb_NO.UTF-8

But here's another question:
when i do a locale -a the lists says: "nb_NO.utf8"
does this affect the way i'm supposed to set LC_* variables? are they still supposed to be set as *.UTF-8 and not *.utf8 ?
personally i haven't experienced any changes with trying both ways..


Back to my original question:
WHERE do i get qt-immodule-bc package? or the qt-immodule patch? (google's been very little help, always end up on the same site
beeing directed in a ring until i give up...)

liucougar 03-20-2005 04:35 PM

*.UTF-8 or *.utf8 is the same, but you should set LC_* to UTF-8

I am trying to help solving your problem: I updated the document a little, which hopefully answered your question. Please have a look at it.

So basicly, do not try to find a qt-immodule enabled Qt if you can not find it, just make Qt work with XIM (like other pure X apps).

Are you sure all the 4 variables are set correctly in the console where you want to start, say kwrite? what's the output of export?

Please also try to set the LC_CTYPE to en_US.UTF-8 (of course it must be existing in your system)

Dodecha 03-21-2005 09:13 AM

Hey, thanks alot man! sorry if i was beeing rude, i did my head in trying to figure out this on my own..

I just started a console in kde, set the ctype and xmodifier vars, started up kwrite and PRESTO, pressing ctrl+space i activated scim and
the toolbar came up!

liucougar 03-21-2005 09:56 AM

well done man
 
so your problem was: those magic variables were not exported correctly


All times are GMT -5. The time now is 11:57 PM.