LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 03-05-2003, 05:26 PM   #1
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Arrow samba and fstab not playing nice


I have a samba server and client sucessfully up and running on my machine. The following command mounts a share from a winxp machine:
mount -t smbfs -o password=p //192.168.0.2/SharedDocs /mnt/winxp
Don't be fooled, though, the following command fails, reporting that the share name is invalid:
mount -t smbfs -o password=p //192.168.0.2/SharedDocs/ /mnt/winxp
While as root I can mount and unmount the filesystem whenever I want, other users can't. And the following entry in fstab also causes the invalid share name error:
//192.168.0.2/SharedDocs /mnt/winxp smbfs password=p,user 0 0
Variations such as removing the "user" argument and adding a "/" to the end of "...Docs" have no effect. I suspect fstab is automatically appending a "/" to the end of the mount command when it runs, and I seem to be powerless to stop it.
Any idea how I can get this to work?
 
Old 03-05-2003, 07:07 PM   #2
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
what is the username? Are you logging in as guest?

How about suid permissions on the mount binaries?

ls -l /bin/mount /usr/bin/smbmnt

chmod 4755 to turn them to suid.
 
Old 03-06-2003, 05:24 PM   #3
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Original Poster
Rep: Reputation: 30
The file smbmnt already existed. I ran ran chmod on smbmnt and mount (I couldn't use the option -l or -I - they produced "invalid option" errors). Still no success on mounting the samba filesystem on bootup. Not even by adding the mount command to rc.local.

The filesystem CAN be mounted after login - but only when I log in as root. I can then logout, login as a normal user, and still access the filesystem - until I reboot.

What else can I try?
 
Old 03-07-2003, 03:13 PM   #4
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
The -l ( the letter 'ell') options wasnt for the chmod. It was for ls, that lists options in the 'long' format.

What does your fstab contain?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu and XP not playing nice. kojima Linux - Distributions 8 10-13-2004 05:29 PM
Grub and XP not playing nice kojima Linux - Software 1 10-13-2004 09:07 AM
Gmplayer Not Playing Nice With Fluxbox 0.9.7 Crashed_Again Linux - Software 3 01-13-2004 12:50 PM
My Linux box is not playing nice warlord07 Linux - Networking 3 09-20-2003 01:41 PM
Windows not playing nice.... absolute0net Linux - Networking 0 07-07-2003 08:03 AM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration