LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Run VLC using root account (http://www.linuxquestions.org/questions/linux-general-1/run-vlc-using-root-account-703319/)

Ashish Sood 02-09-2009 05:50 AM

Run VLC using root account
 
Hi Guys

I m facing a problem while run vlc using root account , when i run vlc nothing is happened and the following message is display

VLC is not supposed to be run as root. Sorry.
If you need to use real-time priorities and/or privileged TCP ports
you can use vlc-wrapper (make sure it is Set-UID root first and
cannot be run by non-trusted users first).


so i want to know is there is any trick to run vlc using root account

all reply is appreciated
thanks in advance
Best Regard
Ashish Sood

Maligree 02-09-2009 06:24 AM

The only way around this which I'm familiar with is recompiling. Pass the --enable-run-as-root flag to ./configure and vlc should be able to run as root.

Ashish Sood 02-09-2009 07:11 AM

But i does not install VLC using tarball, i install it using rpm and i m using fedora 10 so i there is any way to run vlc as root.

Thanks For reply Maligree

repo 02-09-2009 08:16 AM

Quote:

so i want to know is there is any trick to run vlc using root account
There is a reason why it won't run in a root account.
Why do you want to run it in root account?
Just run it as user.

ErV 02-09-2009 08:42 AM

Quote:

Originally Posted by Ashish Sood (Post 3437032)
so i want to know is there is any trick to run vlc using root account

Why do you need this? Root account is for system maintenance only, not for everyday use.

Ashish Sood 02-09-2009 10:16 AM

guys i actually use to login using root account instead non privelage user account , that why i want to know .

Thanks for reply

mrclisdue 02-09-2009 10:55 AM

Well, you already got your answer in the second post. You'll have to remove your existing package and install vlc from source with the appropriate parameters.

Please don't go onto the internet as root, as such irresponsible behaviour puts the rest of us at risk.

Regards,

ncsuapex 02-09-2009 10:58 AM

If you're going to sign in as root all the time you might as well go back to windows.

xXCanisLupusXx 02-19-2009 09:47 AM

Everywhere i'v read about this topic theres always a bunch of people blabbering on about privaleges. This person got his answer, so why all the crap about what he should and should not do, after all its his machine, isn't linux meant to be about freedom and choice , im sure he has already acknowledged the risks of using his machine with the root account and doesn't want it most of this crap.

People should post like maligree, with the actual answer!

soveriegn 03-24-2009 11:20 PM

Sorry to post to a partly old thread, but this is a good solution to this problem (and no, I'm not spamming the forums): http://www.codefaction.net/fixed/
It has the modified VLC source code to strip the checking for root... it has the binary precompiled (i386 arch) and a patch if you want to apply it to the vlc developers code directly. Thanks.

nevyntanis 04-12-2009 07:36 AM

Quote:

Originally Posted by mrclisdue (Post 3437299)
Please don't go onto the internet as root, as such irresponsible behaviour puts the rest of us at risk.

Regards,

Hi, this is the second time u have said this, could u please elaborate, simply pls

shell++ 06-28-2009 09:08 AM

Quote:

Originally Posted by mrclisdue (Post 3437299)
Please don't go onto the internet as root, as such irresponsible behaviour puts the rest of us at risk.
Regards,

-_- come to the dark side, run as root, you will find that you don't have to type sudo in front of anything you type, there will be no locks on the icons on your desktop, and you will notice that you have grown a full beard.

putting the rest of you at risk is a risk I am willing to take ;)

---------------------------------
also:

before doing these steps you may have to purge your existing vlc installation (apt-get purge vlc)

wget -c http://download.videolan.org/pub/vid...0.9.9a.tar.bz2
tar -xvf vlc-0.9.9a.tar.bz2
cd vlc-0.9.9a
apt-get build-dep vlc
./configure --enable-run-as-root
make
make install
------------------------------
start it from command line, (simply type vlc or /usr/local/bin/vlc) it may give you an error about libvlc.so, if it does run:

apt-get install libvlc-dev libvlc2

and just like magic, vlc is workings in root. compiling takes forever though -_- ...

Raveolution 07-07-2009 07:58 PM

Quote:

Originally Posted by soveriegn (Post 3486818)
Sorry to post to a partly old thread, but this is a good solution to this problem (and no, I'm not spamming the forums): http://www.codefaction.net/fixed/
It has the modified VLC source code to strip the checking for root... it has the binary precompiled (i386 arch) and a patch if you want to apply it to the vlc developers code directly. Thanks.

Much thanks for this post. If I wanted an operating system to hold my hand and remind me of what is a potential security problem, I would have gotten Windows Vista.

Logically speaking, Linux should warn you of hazards whenever you plug in your ethernet cable.

Raveolution 07-07-2009 07:59 PM

Quote:

Originally Posted by mrclisdue (Post 3437299)
Well, you already got your answer in the second post. You'll have to remove your existing package and install vlc from source with the appropriate parameters.

Please don't go onto the internet as root, as such irresponsible behaviour puts the rest of us at risk.

Regards,

Plugging into teh intarwebs puts the rest of us at risk. Why isn't there a warning against going online as root?

Hugeman 01-05-2010 03:21 PM

If you are running KDE, the simple thing to do would be to...

1) Click your KDE Start Menu.
2) Applications/Multimedia/Video folder (If running PClinux, Kick off menu)
3) Right click VLC and "edit item" (KDE Menu Editor)
4) Second last option on right side (check box "Run as different user")
5) Enter a profile user name on your computer other then root.
6) Exit and save changes.


I'm no computer linux guru, but this was easy to do and it WORKS!


All times are GMT -5. The time now is 06:37 AM.