LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-17-2007, 04:58 AM   #1
ruj.sabya
LQ Newbie
 
Registered: Mar 2007
Posts: 16

Rep: Reputation: 0
rtld on FC4


Hi,

If I am creating my RPM in Fedora Core 6, one dependency is: rtld. Below is a part of the rpm compilation output.

--------
libjs.so libnspr4.so libssh.so.2 libssh.so.2(SSH_0.2)
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(preun): /bin/sh

Requires: /bin/sh config(app_name) = 1.0-1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.2) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libcrypt.so.1 libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libjs.so libm.so.6 libnsl.so.1 libnspr4.so libnss_dns.so.2 libnss_files.so.2 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) libpthread.so.0(GLIBC_2.3.2) libresolv.so.2 libssh.so.2 libssh.so.2(SSH_0.2) libstdc++.so.6 libstdc++.so.6(CXXABI_1.3) libstdc++.so.6(GLIBCXX_3.4) libz.so.1 rtld(GNU_HASH)
---------

Now if I am trying to install this RPM in Fedora Core 4 it fails on the dependency to rtld.

Any help?

Sabyasachi Ruj

Last edited by ruj.sabya; 07-17-2007 at 05:03 AM.
 
  


Reply

Tags
rpmbuild


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PDF Edit, rtld(GNU_HASH) dependencies yvanchartrand Suse/Novell 3 08-21-2008 06:22 PM
Dual Boot Windows XP & FC4 with FC4 already installed kt8993 Linux - General 8 10-18-2006 04:26 PM
xine needs zlib which needs rtld galen Fedora 3 09-19-2006 01:06 PM
FC4 eMachines ndiswrapper problem (don't think it has anything to do with FC4) unknownmosquito Linux - Laptop and Netbook 2 12-04-2005 11:50 AM
Converting a FC4 dvd to FC4 cd set? prem1000 Fedora 2 06-17-2005 02:14 PM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration