LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Rsync'd my entire drive to an external drive, grub-installed and FAILED to load GUI (http://www.linuxquestions.org/questions/linux-general-1/rsyncd-my-entire-drive-to-an-external-drive-grub-installed-and-failed-to-load-gui-934549/)

rootaccess 03-15-2012 02:44 AM

Rsync'd my entire drive to an external drive, grub-installed and FAILED to load GUI
 
I guess I am trying to make a live usb here following this page
https://wiki.archlinux.org/index.php...kup_with_rsync

I am actually editing the grub.cfg file and took out my original UUID from my previous installation and replaced it with the UUID of the external hard drive. I also changed from hd0 to hd1 since this falls exactly on /dev/sdb1 as the web site as well. My /dev/sdb1 was formatted in ext3, and set to active in fdisk. My fstab only contains the

/dev/sdb1 ext3 defaults 0 0

I did try using the UUID instead of /dev/sdb1 but that did not work either.
When I grub-installed, I mounted my directory to /mnt, and /mnt/dev and mount --bind /dev /mnt/dev as well as chrooted to /mnt and ran grub-install /dev/sdb


I managed to get pretty far, it seems to halt just at the beginning of the GDM3 interface (the GUI). I can move my mouse but it just halts right there.

This was my rsync command after searching very deep for the right folders to exclude. I tried it with the sys folder and that was a mess, I learned these folders are created at boot and not needed to back up:
sudo rsync -av .* /media/passport/ext3/ --exclude=home/user/Videos --exclude=mnt --exclude=media --exclude=proc --exclude=var/spool/squid --exclude=home/user/.mozilla/firefox/*/Cache --exclude=sys --exclude=tmp/* --exclude=lost+found --include=dev/console --include=dev/initctl --include=dev/null --include=dev/zero --exclude=dev/*

(of course user is in lieu of my real username)
Also, from testing out with other directories between each other, the correct syntax at least with my rsync version in Debian is to NOT include quotes in the --exclude or --include option. Also the .* was something I had spent hours looking for how to copy EVERYTHING from the root folder including all hidden files and folders and works like a charm.

So having said pretty much everything I have done, what have I done wrong or is it just not possible to make my filesystem boot up as if it were another one of my filesystems?

Thanks a lot for any input.

rootaccess 03-15-2012 01:09 PM

bump


All times are GMT -5. The time now is 03:03 PM.