LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Rsync set permissions destination (http://www.linuxquestions.org/questions/linux-general-1/rsync-set-permissions-destination-603480/)

Abstractt 11-30-2007 07:23 AM

Rsync set permissions destination
 
Hi Everyone,

I'm using rsync to backup all of the websites we have. It's logging in with ssh and using ssh keys so it all goes smoothly.

I like to change the permissions, ownership and group this command is setting on the downloaded files. These permissions, ownerships and groups are completly different from the one we use on the server. Is it possible to make this happen within the rsync command? Or should i run a shell script afterwards to change this?

This is the adjusted (for security reason) command I'm using:

rsync -rlvz --size-only --update --exclude="*\.zip" --exclude="*_-_*" --owner=admin --group=nobody --chmod=a+rwx,g+rwx,o+r -e 'ssh -i [ssh key]' [user]@[server]:[source] [destination]

My quess is that --owner=admin --group=nobody doesn't exists and should be used in the form --owner --group for perserving the ownership and group of the source.

I think the option --chmod=a+rwx,g+rwx,o+r is correct, but strange enough it doesn't change the persmissions to 774. Can someone help me?

Thanks Arian

trickykid 11-30-2007 07:41 AM

If these are backups, I'd say you may want to preserve the unique ID's and Permissions on these files so if or when you need to restore, they'll be intact as their original owner and permission without any interaction.

If you do insist on changing the permissions, might want to somehow write a script that knows how to revert back before a restore.. ;)

Abstractt 11-30-2007 07:52 AM

When data needs to be restored it will be restored ftp, which will set the right permissions after uploading. So we don't care about losing the original ownerships and permissions.

Do you know how I can change the permissions, ownerships and groups on the downloaded files? What is wrong with the command I'm using?

hendrohwibowo 09-30-2010 02:05 AM

i try this
 
--chmod=a+rwx,g+rwx,o-wx, resulting in 774


All times are GMT -5. The time now is 11:51 AM.