LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-31-2013, 07:13 AM   #1
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 400

Rep: Reputation: 41
rootdelay=90 not works ?


Hello!
I have one of old machines, on centos, wuth grub and kernel 2.4.20.
on one not-so-great day it after reboot show "cannot open root device, kernel panic!". i try various thinks, check all hardware, and my "now"
idea is involve a rootdelay before kernel try mount root partition, because before that i cannot see strings like a "ATA0: founda sata disk ...."
that is P4 system on 845 or 865 chipset with pata and sata on board. times agoo all work fine, reboots too, but yesterday something changes.
system is on only sata disk. i try to in grub menu put rootdelay=10 rootdelay=20 and even rootdelay=90 - no changes, all things do as fast as without "rootdelay" options.
i boot in knoppix via live dvd, mount boot partition of systemdisk, and edit grub.cfg - adding to end of kernel line rootdelay=90 - also not any effect.
anyeone have a similar experience \ ideas what i can do, for waiting to kernel detect system sata disc before try to mount root partition?
 
Old 02-01-2013, 05:23 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,483

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
I would assume that message is coming from your initrd - the rootdelay is passed to the real kernel. You seem not to be getting that far.
Have you done a fsck on all the partitions on the internal disk ?. You should be able to do that from the live DVD.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
had to use rootdelay with SCSI drive to boot on ubuntu 8.10. any ideas why? rizwanrafique Linux - Software 1 02-22-2009 08:41 AM
Strangest FTP error on RHEL5. gFTP works. RHEL4 works too. GuitsBoy Linux - Software 1 04-10-2008 09:29 AM
Mounting works, playing music works, reading tags doesn't Celettu Linux - Newbie 7 08-23-2006 01:27 PM
DNS look up works, ping only works for some sites any ideas? Mantrout Linux - Wireless Networking 3 01-29-2006 12:59 PM
XAWTV works, videodog works, motion works but how to code my own? rylan76 Linux - Hardware 0 01-06-2006 07:30 AM


All times are GMT -5. The time now is 10:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration