LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-24-2004, 11:45 PM   #1
jworld900
LQ Newbie
 
Registered: Jan 2004
Posts: 9

Rep: Reputation: 0
Restarting the X Server


When i change my display size, it asks me to restart the x server, how do i do that?????
 
Old 01-25-2004, 12:09 AM   #2
gokul
Member
 
Registered: Jun 2002
Distribution: mandrake,redhat,fedora
Posts: 34

Rep: Reputation: 15
Logout and login. That will do it automatically. ( if u r in the GUI mode)
OR
Switch to init 3 and back to init 5
OR


(I guess if u had restared ur computer already, ur settings would have been applied)
 
Old 01-25-2004, 12:10 AM   #3
rlkiddjr
Member
 
Registered: Feb 2002
Distribution: FreeBSD 4.9
Posts: 69

Rep: Reputation: 15
1. Log out of KDE, Gnome, or whatever you use.
2. Press together; Ctrl, Alt, Backspace. This will send you into text mode.
3. Log in with username and password while in text mode.
4. Type startx and hit enter.
 
Old 01-25-2004, 12:45 AM   #4
gokul
Member
 
Registered: Jun 2002
Distribution: mandrake,redhat,fedora
Posts: 34

Rep: Reputation: 15
FYI
ctrl+Alt+BackSpace restarts the X-server, killing all processes that are running uder X.
It will not send u into a text mode.

Logging out automatically restarts the X-server.
 
Old 01-25-2004, 02:15 AM   #5
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 30
Quote:
ctrl+Alt+BackSpace restarts the X-server, killing all processes that are running under X.
That depends on whether you boot in text mode or GUI mode. If it is in text mode, then Ctrl+Alt+backspace will drop you in the text mode. Otherwise, it will restart the X-server.

Most of the experienced linux users boot into the text mode, as it gives them more control and flexibility, while newbies generally boot into the graphical mode. So,, rlkiddjr was correct in his answer..

And gokul, don't think that I am spamming you, but don't say others are incorrect if you are not a guru on that topic, as you may not know it well.
 
Old 01-25-2004, 02:36 AM   #6
gokul
Member
 
Registered: Jun 2002
Distribution: mandrake,redhat,fedora
Posts: 34

Rep: Reputation: 15
I'll keep that in mind.
Thanks.
I stand corrected.
(I guess i was in a hurry to help and be right. well , Iam no guru.atleast not yet. Thank goodness my advice did not endup being harmful)
 
Old 01-25-2004, 02:41 AM   #7
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 30
Good, gokul, I see that you are taking this positively. Not every one are like this, and so I am happy to see your response.

And, don't stop trying to be helpful to others!
 
Old 01-25-2004, 02:46 AM   #8
gokul
Member
 
Registered: Jun 2002
Distribution: mandrake,redhat,fedora
Posts: 34

Rep: Reputation: 15
Thanks for the encouragement. I have seen forums full of nonsense exchanges.

I'll continue to help, but taking caution.

(Before this thread becomes nonsense,lets stop here and may be send private messages if required)
 
Old 01-25-2004, 03:02 PM   #9
jworld900
LQ Newbie
 
Registered: Jan 2004
Posts: 9

Original Poster
Rep: Reputation: 0
when i do log out and in, it just goes back to the screen size before i changed it. do you know how to finish that.
 
Old 01-26-2004, 01:15 AM   #10
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 30
Try changing the resolution in the xfree86 config file..

It will be under /etc/X11/XF86Config.

It will be understandable and try to change the default resolution in that file.

Post if you have any problems
 
Old 01-27-2004, 03:15 PM   #11
jworld900
LQ Newbie
 
Registered: Jan 2004
Posts: 9

Original Poster
Rep: Reputation: 0
yeah. when i tried to edit the file, it wouldnt let me. when i finally was able to (using vi) it reverted back to the old settings once i closed it. What program should i use to edit the file.
 
Old 01-27-2004, 03:44 PM   #12
Megamieuwsel
Member
 
Registered: Sep 2002
Location: Haarlem , the Netherlands
Distribution: VectorLinux SOHO 5.1
Posts: 465

Rep: Reputation: 35
Any editor would do just fine , be it VI , pico , nano or whatever you're comfy with.
Ofcourse you must save before you close the editor.....
Then restart the x-server.
 
Old 01-28-2004, 11:21 AM   #13
gokul
Member
 
Registered: Jun 2002
Distribution: mandrake,redhat,fedora
Posts: 34

Rep: Reputation: 15
As Megamieuwsel said u have to save the file after editing it.
If it says u r not allowed to alter the file....try to edit the file as user: root
Try logging in as root and edit it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change from Clone to LeftOf mode without restarting X server malo_umoran Slackware 1 11-24-2005 06:34 PM
restarting x server igracgq Red Hat 4 12-14-2004 09:44 PM
Does sending processes the 9 signal, or restarting the X server cause damage? Squall Linux - General 1 06-07-2004 10:14 AM
Restarting X Server unwrittenLaww Linux - Newbie 11 04-20-2004 01:34 PM
restarting x server? pyschomike15 Linux - General 4 11-02-2003 07:13 AM


All times are GMT -5. The time now is 10:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration