LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Rescan for USB Devices (http://www.linuxquestions.org/questions/linux-general-1/rescan-for-usb-devices-754916/)

newmanium2001 09-13-2009 06:00 PM

Rescan for USB Devices
 
Hi all,

I've been searching pretty furiously for the answer to this question, but to no avail. (distro is Fedora 11 btw)

When I log onto my Gnome session, about 30% of the time my mouse doesn't work. If I unplug it and plug it back in, it works again, but needless to say, reaching all the way behind my desktop and doing this is not very convenient.

All I think I would need to do is rescan the USB bus to "redetect" the mouse so to speak, but I can't figure out how this is done. Obviously the OS does some sort of command like this when Linux boots, right? Or is USB just all magic?

w1k0 09-13-2009 06:56 PM

Sorry! I copied from the editor and pasted here by mistake the reply to the another question from the another thread. Now I removed it.

lutusp 09-13-2009 09:20 PM

Quote:

Originally Posted by newmanium2001 (Post 3681516)
Hi all,

I've been searching pretty furiously for the answer to this question, but to no avail. (distro is Fedora 11 btw)

When I log onto my Gnome session, about 30% of the time my mouse doesn't work. If I unplug it and plug it back in, it works again, but needless to say, reaching all the way behind my desktop and doing this is not very convenient.

All I think I would need to do is rescan the USB bus to "redetect" the mouse so to speak, but I can't figure out how this is done. Obviously the OS does some sort of command like this when Linux boots, right? Or is USB just all magic?

I just Googled this issue, and it appears that issuing the "lsusb" command will rescan for USB devices. You could create a new desktop icon that, when clicked ... oh, crap. I guess that won't work. :)

I guess you will have to press Ctrl+Alt+F2, log in as root, and issue the "lsusb" command from there. Then press Ctrl+Alt+F7 (on an up-to-date distribution) to go back to X Windows.

And this might not work, depending on what "lsusb" actually does. A better solution might be to connect your mouse to a better USB port. Test your USB ports -- connect the mouse to different USB ports, see if there's one that doesn't disable your mouse when you log off. And don't attach either your keyboard or your mouse to a peripheral USB extension box.

Reeb xoxo 08-06-2011 02:40 PM

doesn't work
 
the command doesn't work, just shows:
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

no auto-mounting

OneTinSolider 06-05-2013 09:26 PM

A simple "udevadm trigger" should work

eklavya 06-06-2013 01:20 AM

your mouse, keyboard and screen are controlled by Xorg. I have found in the past that things could break for no reason, such as a single key becoming non-responsive, requiring me to map it explicitly with xmodmap.


All times are GMT -5. The time now is 01:31 PM.