LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-15-2003, 06:02 PM   #1
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Rep: Reputation: 15
remove trash icon on Gnome 2.4 desktop


Hey, I use Gnome 2.4 and I think it's really beautiful. Only the 2 icons the desktop, trash and home folder are making me crazy, I don't want them there but I can't remove them by right clicking them (reminds me of my computer and recycle bin on some os I once used to use). Is there a way to remove these?
 
Old 10-15-2003, 07:41 PM   #2
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Hi,

The way I did it (on earlier version of Gnome, but should be the same), is by deleting it....
'rm -rf /home/username/.gnome-desktop/Trash'

Good luck.
>Craig
 
Old 10-16-2003, 02:12 AM   #3
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Original Poster
Rep: Reputation: 15
Haha, stupid of me not to check that, thanks a lot!
 
Old 10-16-2003, 02:23 PM   #4
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Original Poster
Rep: Reputation: 15
Unfortenately, that doesn't work, there isn't a gnome-desktop dir I checked the other gnome dirs in my homedir but I don't see the files that could be the icons
 
Old 10-16-2003, 07:28 PM   #5
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Hi,

The directory is .gnome-desktop there is a full stop, or period before .

The . makes it hidden that's why you can't see it

>Craig
 
Old 10-17-2003, 02:16 AM   #6
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Original Poster
Rep: Reputation: 15
Lol, I know what the dot means, but that dir just isn't there
 
Old 10-18-2003, 03:58 PM   #7
blixel
LQ Newbie
 
Registered: Sep 2003
Posts: 22

Rep: Reputation: 15
Deleting the Trash and Home files won't work anyway. I've tried it. As soon as you restart X they come. I've found that setting ~/.gnome-desktop to read-only (i.e. chmod 400 ~/.gnome-desktop) will stop the icons from appearing. But then you get a warning message every time you start X which is just as irritating.
 
Old 10-18-2003, 04:42 PM   #8
speter
Member
 
Registered: Sep 2003
Location: Edison, NJ
Distribution: Fedora, Mac OS X
Posts: 313

Rep: Reputation: 30
You can also disable or remove Nautilus, since that is what's drawing the icons to the desktop.

Steve
 
Old 10-19-2003, 05:52 AM   #9
dfuse
Member
 
Registered: May 2003
Location: Leuven, Belgium
Distribution: Gentoo Linux
Posts: 42

Original Poster
Rep: Reputation: 15
I solved it. I just selected them on my desktop and pressed delete on my keyboard I always right-clicked and the delete option was greyed out. I also found out that icons you put on the desktop reside in ~/Desktop in Gnome 2.4 to conform with the xfree desktop standards, although this conflicts with the manual which says they are in .gnome-desktop. The trash and home folder icon are not in that directory though but anyways they are gone now, and don't reappear when restarting X. You can also disable all icons on your background by typing: gconftool2 --type bool --set /apps/preferences/nautilus/show_desktop false
 
Old 05-21-2004, 10:18 AM   #10
petr.pisoft
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Lightbulb remove trash icon - gnome 2.4.1

There is no conf file for the icons like Trash or Home etc. in gnome 2.4.2. (e.g. gentoo distribution) and there are two ways how to remove them. First, you can by 'gnome-session-properties' change nautilus feature 'restart' to 'normal' and then just type killall nautilus. Well, you prabably meet some problems with background etc. next time you login. The other way is very simple and it works!! - type 'gconf-editor' (or Applications - System tools - Configuration editor) and then try to find Apllication - nautilus - preferences and uncheck the 'show_desktop' box. That's all folks!

Petr
 
Old 06-06-2009, 09:29 AM   #11
Silverwing
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Rep: Reputation: 0
at last, I know the fix :D

After trying around, I found out that setting show_desktop false stops nautilus from drawing the desktop wallpaper as you change it. You better enable show_desktop and change these values in gconf editor:

apps -> nautilus -> desktop:
computer_icon_visible unchecked
home_icon_visible unchecked
trash_icon_visible unchecked

Works better for me
 
Old 08-01-2011, 06:46 PM   #12
sergani
LQ Newbie
 
Registered: Jan 2010
Distribution: Fedora, CentOS, OpenSuse, Oracle Enterprise Linux, MacOSX
Posts: 27

Rep: Reputation: 0
Thanks a lot!!!!

Quote:
Originally Posted by Silverwing View Post
After trying around, I found out that setting show_desktop false stops nautilus from drawing the desktop wallpaper as you change it. You better enable show_desktop and change these values in gconf editor:

apps -> nautilus -> desktop:
computer_icon_visible unchecked
home_icon_visible unchecked
trash_icon_visible unchecked

Works better for me
You're the man!!!
Thanks a lot man!!!

I've been working on changing my Fedora 14 to have a Mac look -cause I have one and got used to the UI-, and this you described, along with Avant Window Navigator -along with some additions- just did the job :-)

This is my current desktop...
http://www.imagehosting.com/photo/sc...2?context=user
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop Trash icon disappears in kde moxieman99 Fedora - Installation 3 11-23-2005 04:02 PM
Desktop Trash icon noxious Slackware 9 08-27-2005 12:39 PM
Lost my Trash Can from Gnome Desktop h1tman Slackware 3 07-28-2004 10:21 PM
Changing Trash Icon in Gnome? carlosinfl Linux - Software 0 07-26-2004 04:41 PM
How could i remove the trash icon in KDE(I HAVE TWO) whepin Linux - Newbie 5 12-31-2002 04:35 AM


All times are GMT -5. The time now is 11:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration