LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Remote X Server Can't Open Display (http://www.linuxquestions.org/questions/linux-general-1/remote-x-server-cant-open-display-657727/)

markjuggles 07-23-2008 11:52 AM

Remote X Server Can't Open Display
 
Hi,

I seem to have a configuration issue that is preventing me from displaying an X application using an X server on a different machine.

The application machine is an embedded Linux board based on the AVR32.

I would like to run an X application like this:

# export DISPLAY=10.1.60.59:0
xeyes
Error: Can't open display: 10.1.60.59:0
# xlogo
Error: Can't open display: 10.1.60.59:0

The X server is reachable:
# ping 10.1.60.59
PING 10.1.60.59 (10.1.60.59): 56 data bytes
64 bytes from 10.1.60.59: seq=0 ttl=127 time=2.702 ms
64 bytes from 10.1.60.59: seq=1 ttl=127 time=1.835 ms

The server lets me display from a Ubuntu box on the same network using the same DISPLAY setting. The network configuration is the same:

Application Board:
# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 04:25:FE:DE:AD:09
inet addr:10.1.30.218 Bcast:10.1.31.255 Mask:255.255.254.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

Ubuntu Box:
$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:B0:D0:DE:9F:6C
inet addr:10.1.30.219 Bcast:10.1.31.255 Mask:255.255.254.0


What am I missing here?

Thank you,

Mark

TB0ne 07-23-2008 01:13 PM

Quote:

Originally Posted by markjuggles (Post 3223914)
Hi,

I seem to have a configuration issue that is preventing me from displaying an X application using an X server on a different machine.

I would like to run an X application like this:

# export DISPLAY=10.1.60.59:0
xeyes
Error: Can't open display: 10.1.60.59:0
# xlogo
Error: Can't open display: 10.1.60.59:0

On your xserver, you have to allow incoming connections. Do a "ps -ef | grep listen", and see if it returns your Xserver daemon. If it returns a line with "-nolisten" in it (the default for lots of distros), you'll have to change your X configuration to remove the -nolisten option. I've never done it on ubuntu, so I can't be of much help there, but I'm sure there are lots of docs on the net.

After you get that going (and don't just log out...you have to either reboot or do a CTRL-ALT-BACKSPACE to restart your X server), you have to allow the connections to take place. As root, you can either do "xhost +" (unsafe, allows ANYONE to start remote windows on your machine), or "xhost <ip address of remote machine>" (allows just that machine to fire up an X session.

markjuggles 07-23-2008 01:59 PM

Good thought.

The X Server is a windows box running Xming. Permissions were set to allow any host to write to the X server. This was tested successfully from a Red Hat box inside my intranet from a couple of states away.

Also, the XO.hosts file was updated to to include all three Linux machines with no change in behavior. Ubuntu and Red Hat can run xeyes but the embedded board adjacent to the Ubuntu cannot.

Nadia_ 04-11-2014 05:21 AM

solved
 
I tried every solution you presented here with no success. however, I tested it at home with ssh Secure shell and it worked. So, instead of using putty I used ssh Secure shell program, enabled X11 and it worked. With putty I can't manage to make it work.

TB0ne 04-15-2014 03:04 PM

Quote:

Originally Posted by Nadia_ (Post 5150621)
I tried every solution you presented here with no success. however, I tested it at home with ssh Secure shell and it worked. So, instead of using putty I used ssh Secure shell program, enabled X11 and it worked. With putty I can't manage to make it work.

Right...that's because putty is ONLY an SSH terminal program, with no X11 support at all.


All times are GMT -5. The time now is 07:45 AM.