Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 01-04-2004, 06:44 AM   #1
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Rep: Reputation: 16
Radeon 9200, screen resolution


I have an ATI Radeon 9200. When I got it I download it the driver from ATI and installed it with no problem. I didn't have 3d acceleration working but everything else was fine. I tried playing quake and it was ok.

Some days later, I don't know what happened but X would start. It was hanging displaying only a black screen. The whole system halted and I had to press reset to get it back.

I tried reconfiguring X but if I used that driver from ATI, X would hang again.

I decided to find another way to make it work and I found in this forum this howto

I followed it and X now starts and looks ok. Still no 3d acceleration though.

Now for the resolution part:

I tried setting it from redhat-config-xfree86 but it seems to ignore me and writes XF86Config file with modes 800x600 and 640x480 only.

I edited XF86Config file and added 1024x768 but when I start X, it startx in 800x600. I tried ctr+alt++ to cycle trough resolutions but it only cycles through 800x600 and 640x480

If I delete 800x600 and 640x480 and leave only 1024x768 X doesn't start and displays this error message: no screens found

What else can I do?



glxgears says only 70FPS. I was expecting more! What do you think?

Pentium III working at 894MHz
ATI Radeon 9200 256MB
Generic monitor (I don't think it came with manual)
Old 01-04-2004, 06:55 AM   #2
Registered: Oct 2003
Location: Portugal
Distribution: Gentoo
Posts: 116

Original Poster
Rep: Reputation: 16
DAMN! Right after my post I went to redhat-config-xfree86 to check my monitor settings.
Changed it to Generic Monitor 1280x1024 @ 60Hz and it now works

Enabling page flipping resulted in an increase of FPS from 70 to around 148FPS
Still, isn't 148FPS in glxgears kind of low?

And how do I enable 3D? From the how to:

You can try glxinfo and confirm DRI for 3D is enabled:

# glxinfo
display: :0.0 screen:0
direct rendering: Yes
but my direct rendering is "No". Does this mean 3D acceleration is not working? I have the "Enable Hardware 3D Acceleration" option checked in redhat-config-xfree86.

Last edited by Covel; 01-04-2004 at 07:03 AM.
Old 01-04-2004, 02:37 PM   #3
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
i don't know what kind software you are using, right or wrong driver.

You will never got your direct rendering working if you are using the kernel which comes with rh9 or 2.4.20-8. there is a support problem with the kernel.
if your card have 256mb memory. then it should be running at 3000 fps.
I got 9600 pro and it's running around 4000 fps.
Running kernel-2.4.23 from
First i got with v.3.7.0 at
first just uninstall all your drives from previous installation.
install the driver by typing "rpm -ivh --force" since you are using 4.3.0 xfree86
then use external /dev/agpgart .
type "echo "/sbin/modprobe agpgart" >> /etc/rc.local" and "echo "/sbin/modprobe fglrx" >> /etc/rc.local" as root.
then it should ready to go.
Old 01-05-2004, 09:41 AM   #4
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
I'd be interested in knowing how you installed ATI's driver. I have a 9200 as well, and I downloaded and installed the RPM - and I still don't see the option for the 9200 in display config.

I got it to work (sort of) by adding 'ChipId 0x4242' to my XF86Config file. My resolution is fine and dandy, but the refresh rate is nowhere close to how it is in windows.

An oddity: I have a stereo reciever on the top shelf of my desk, just above my monitor. If I'm running windows, no issues. if I turn it on under linux, it makes my monitor go nuts.

*scratches head*
Old 01-05-2004, 11:27 AM   #5
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
well, first you have to install it in terminal
assume the name of the rpm was file.rpm
Note: you must have your kernel source installed from your installation disc.
you install it by "rpm -ivh --force file.rpm"
you have to run "fglrxconfig" to reconfigure your xfree86config file.
if you want to get 3d acceleration.
then use external /dev/agpgart.
add "/sbin/modprobe agpgart"
and "/sbin/modprobe fglrx" to your /etc/rc.local file


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 05:10 PM
Radeon 9600 Drivers Have Broken my Screen Resolution RAMMS+EIN Linux - Hardware 1 05-28-2005 11:12 AM
Resolution setting for ATI radeon 9200 dimarcoe Linux - Hardware 1 08-30-2004 07:02 PM
Xinerama on Radeon 9200 almost works, but DVI screen is fuzzy 524x1200 jaufrec Linux - Hardware 2 03-06-2004 11:54 PM
Mandrake 9.2 Radeon 9200 (im using lynx to post) no screen found? Optyx Mandriva 1 03-04-2004 02:09 PM

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration