LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-15-2007, 12:21 PM   #1
maxchock
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Rep: Reputation: 0
PXE-E32 TFTP open timeout


Hi all, I've setup linux as PXE server follow the page below
http://www.tuxdocs.net/wiki/index.ph...e_for_pxe_boot
When I start my client pc, it show:
-----------------------------------------------------
Client IP 192.168.1.251 MASK:255.255.255.0 DHCP IP: 192.168.1.4
Gateway IP: 192.168.1.1
PXE-E32: TFTP open timeout
TFTP...
-------------------------------------------------------

If I wait 3 to 5 minutes, it will just boot from its' local harddisk. I "tail -F /var/log/messages" something related return such as..
-----------------------------------------------------------
Jan 14 21:44:35 gamesrv dhcpd: No hostname for 192.168.1.251
Jan 14 21:44:35 gamesrv dhcpd: DHCPDISCOVER from 00:e0:4d:02:af:93 via eth0
Jan 14 21:44:35 gamesrv dhcpd: DHCPOFFER on 192.168.1.251 to 00:e0:4d:02:af:93 via eth0
Jan 14 21:44:37 gamesrv dhcpd: No hostname for 192.168.1.251
Jan 14 21:44:37 gamesrv dhcpd: DHCPREQUEST for 192.168.1.251 (192.168.1.4) from 00:e0:4d:02:af:93 via eth0
Jan 14 21:44:37 gamesrv dhcpd: DHCPACK on 192.168.1.251 to 00:e0:4d:02:af:93 via eth0
----------------------------------------------------------------

So, apparently, the client pc prove that dhcp is working, but somehow the tftp server doesn't really respone.. Since I add it in xinetd, so I "/sbin/chkconfig --list tftp" and it return
"tftp on"
the tftp config file in "/etc/xinet.d/tftp" show this

-------------------------------------------------------------

service tftp
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -v -s /tftpboot
per_source = 11
cps = 100 2
flags = IPv4
}
-------------------------------------------------------------

Please help me on this.

Thanks & regards,
Max.
 
Old 01-15-2007, 07:23 PM   #2
maxchock
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
anyone help please??

THanks.
 
Old 01-22-2007, 02:55 AM   #3
thlware
LQ Newbie
 
Registered: Jul 2003
Location: RSA
Distribution: Redhat
Posts: 2

Rep: Reputation: 0
Hi Max, do you get any solution for this ? i get the same error .. but still i am not able to find any solution.
 
Old 01-30-2007, 03:31 AM   #4
maxchock
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by thlware
Hi Max, do you get any solution for this ? i get the same error .. but still i am not able to find any solution.
my solution is, get rid of Fedora Core and install CentOS, and it works dramatically....

Max.
 
Old 03-25-2008, 01:04 PM   #5
kumar.craja
LQ Newbie
 
Registered: Aug 2006
Posts: 12

Rep: Reputation: 0
Solution to the problem

Quote:
Originally Posted by maxchock View Post
my solution is, get rid of Fedora Core and install CentOS, and it works dramatically....

Max.
This problem occurs because of firewall problem. Open the port no 69(tcp and udp) in firewall which is the default tfpd port. Otherwise simply disable the firewall and try your pxe boot from client.
 
Old 12-02-2008, 10:56 AM   #6
shantanu_gadgil
LQ Newbie
 
Registered: Dec 2008
Posts: 6

Rep: Reputation: 0
For me disabling the firewall DID NOT help.

What did the trick was:
1. Keep the DHCP (dhcpd) and the TFTP (xinetd + tftp) server on the same machine.
2. use the DHCP directive "next-server" to point to the same machine.

What I have also observed is that this is related to the LAN card...
It works OK for an Intel card but the timeout thing happens for a RTL 8139 chipset card.

Maybe using dnsmasq might give people different results ???

Regards,
Shantanu
 
Old 12-04-2008, 01:46 AM   #7
shantanu_gadgil
LQ Newbie
 
Registered: Dec 2008
Posts: 6

Rep: Reputation: 0
Hi all,
Please refer:
http://www.linuxquestions.org/questi...15#post3361915

... if that helps ...

Cheers,
Shantanu
 
Old 02-04-2010, 01:43 PM   #8
sabir_mustafa
Member
 
Registered: Aug 2009
Location: Rawalpindi
Distribution: RHEL 5, CentOS
Posts: 38

Rep: Reputation: 16
Hi:
Since the reply is too late but I want to share.
I have faced the same problem in Fedora 11 PXE server, the solution is

1. use system-config-firewall and allow the tftp server port or disable the firewall.
2. Disable the iptables using service iptables stop
 
Old 02-09-2010, 06:39 AM   #9
shantanu_gadgil
LQ Newbie
 
Registered: Dec 2008
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by sabir_mustafa View Post
Hi:
Since the reply is too late but I want to share.
I have faced the same problem in Fedora 11 PXE server, the solution is

1. use system-config-firewall and allow the tftp server port or disable the firewall.
2. Disable the iptables using service iptables stop
Please check http://www.linuxquestions.org/questi...09#post3361909

This is not a firewall issue ... its a hardware issue specific to the RTL 8139 cards (maybe others chipsets too!) and the way the DHCP/TFTP server are located.
 
Old 05-09-2012, 04:28 PM   #10
Hoagie572
LQ Newbie
 
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
BlockSize

Just hit this prblem with a laptop running a realtek NIC. Setting the tftp server blocksize to 512 got it all going.
 
Old 07-02-2012, 02:54 PM   #11
fodya
LQ Newbie
 
Registered: Nov 2011
Posts: 2

Rep: Reputation: Disabled
I had the same problem. After going through many posts and trying all stuffs it did not help.

I compared it with a working server and found the xinted services were not running. After turning it ON the PXE built started the very next second.
 
Old 09-12-2013, 07:52 AM   #12
jringoot
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
check xinetd

I had the same issue, everything looked fine, just xinetd was not started:
try

chkconfig --list xinetd
and
chkconfig xinetd on
and
service xinetd start

BTW: you can also verify if tftp is serving with nmap:
nmap -sU localhost

(The U is for scanning UDP services)

Last edited by jringoot; 09-12-2013 at 07:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error "TFTP open timeout" Ogi Linux - Networking 5 10-07-2009 09:16 AM
PXE-TFTP Installation Server dipuasks Linux - General 6 12-04-2008 01:44 AM
PXE TFTP thin client paul_mat Linux - Networking 2 01-19-2006 06:41 AM
network booting and tftp potential / pxe rhoyerboat Linux - Networking 1 08-30-2005 05:32 AM
Network Install PXE/BootP/TFTP unixvillian Linux - Software 1 06-09-2004 02:11 AM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration