LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   problems with ruby on ubuntu linux [rubygems also] (http://www.linuxquestions.org/questions/linux-general-1/problems-with-ruby-on-ubuntu-linux-%5Brubygems-also%5D-4175444869/)

BlackHawk 01-09-2013 05:15 PM

problems with ruby on ubuntu linux [rubygems also]
 
hello everyone,

While the other day i decided to try and upgrade from ruby1.8 to ruby1.9 and i installed rvm and used rvm to upgrade to ruby1.9

now when i do ruby --version i get this

ruby 1.9.3p362 (2012-12-25 revision 38607) [x86_64-linux]

and i thought everything was going fine but now I am getting some error messages and I am not really sure what I can do to fix the problem.

Code:


After this operation, 0B of additional disk space will be used.
Setting up rubygems1.8 (1.3.7-1ubxd2) ...
update-alternatives: error: alternative gem can't be master: it is a slave of ruby
dpkg: error processing rubygems1.8 (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of rubygems:
 rubygems depends on rubygems1.8 (= 1.3.7-1ubxd2); however:
  Package rubygems1.8 is not configured yet.
dpkg: error processing rubygems (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 rubygems1.8
 rubygems
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now i am not sure what I can do to fix this problem...?


What do you guys recommend?

I am on ubuntu lucid and I was thinking maybe i should just go back down to ruby1.8 but if that is the best solution I am not sure how to do that.

Any input on this would be greatly appreciated as I am really stuck on this one. I search hours on google and there is not too much on this subject.

I thank you all for your time and your assistance.

Oh, if you guys think i should maybe completely remove ruby and ruby gems and re install everything, how would i go about doing that? I think this may be a viable option.

-BlackHawk

Ztcoracat 01-15-2013 11:41 PM

Hi:


The problem might be that you are missing libc6.
One problem I see is:
Quote:

dependency problems prevent configuration of rubygems:
The other problem I think is:
Quote:

Package rubygems1.8 is not configured yet.
Dependencies- a program or a library that another program needs to run.
rubygems isn't working because it is not configured-
The problem might be that you are missing libc6.

Fixing dependencies
dpkg --configure --pending
If dpkg quits with an error while apt-get install, upgrade, or dist-upgrading try running this to configure the packages that were already unpacked. Then try apt-get - f install, upgrade, or dist-upgrade -f, and then try apt-get install, upgrade, or dist-upgrade again. Repeat as needed. This usually resolves most dependency problems (also, if it mentions a specific package for some reason, you might want to try installing or removing that package)

This page is helpful too:
http://ilostmynotes.blogspot.com/201...s-prevent.html


Here's a article at Ubuntu that might help.
http://askubuntu.com/questions/12974...f-libnih-dbus1

To remove ruby you should be able to use the Ubuntu Software Center Manager for remove/install-

Hope this helps


All times are GMT -5. The time now is 01:06 AM.