LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-29-2003, 06:18 AM   #1
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
Unhappy Problems with NVIDIA drivers and GeForce4 in Fedora


Hi,
I'm having problems with my nVidia GeForce 4 440 mx on Fedora. I've just installed the latest nVidia drivers (5328) but they don't seem to load correctly.

When running glxgears I get a framerate of 6.400 and tux racer gets about 1 fps in menu.

I've modified the XF86Config file as said in readme by commenting Load "dri" and changing Driver from "nv" to "nvidia". It shows me nVidia logo on startup so something has to be correct but also that graphical loading thing on XWindow (It is XWindow right?XFree86?) doesn't show up anymore.

Driver readme said that when running xdpyinfo, extensions should have NVIDIA-GLX in it but it seems to be missing there. Extensions have GLX and NV-GLX as it should.

I've been searching the net for 12 h now, rebooted about 20 times and just got XWindow not to load, which is fixed now. Any help would be welcome. I've been using linux only a few days now so be clear enough. Thanks in advance.

And by the way is there a way to restart this XWindow thing without rebooting so wouldn't have to reboot whole computer every time I try new configuration ?
 
Old 12-29-2003, 08:06 AM   #2
ts_sudarshan
LQ Newbie
 
Registered: Oct 2003
Location: Bangalore
Distribution: Arch, SUSE OSS
Posts: 23

Rep: Reputation: 15
i286: hi, first of all to restart XWindow (actually the XServer) there is an option for it KDM(KDE login manager). This option is not present in GDM(GNome login Manager) which Fedora uses by default. So, to restart it, just press the 3 key combination (ctrl-alt-backspace). And your Xserver restarts and prompts you with the login... I'am also using Fedora and I've installed the nvidia(4496) driver that comes as a .run package for my nVidia GeForce 2 mmx card and i find no problem.. So, as far as that problem of yours is concerned, I've no solid answer. ATB.
 
Old 12-29-2003, 08:14 AM   #3
nexx_au
Member
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 69

Rep: Reputation: 15
Ok i dont know if this will fix your problem, but on Fedora i had to delete (or rename to be safe) the two files in /usr/X11R6/lib/tls

Also Ctrl+Alt+Backspace will restart X and return you to the graphical login screen.
 
Old 12-29-2003, 08:50 AM   #4
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Post

Thanks for your replys. I tried that /usr/X11R6/lib/tls but it's empty.
Maby I should try deleting these newer drivers and try those 4496. But how do I unistall them? Just removing the files installation made and edit XF86Config back to its original? Been using linux for 4 days now so I really don't know.

edit:
Ok I got them out with that nvidia-installer that was installed with the drivers and I'm now going to try older drivers. Got 300 fps on that glxgears instead of 6.400 so at least it used those drivers for rendering

edit:
Umm now it wants kernel headers. Did some googleing and found out that they should be in Fedora CDs as .rpm . I think there was an option to install these in Fedora installation so is there a program that could be used to install these parts from CDs or do I have to reinstall whole Linux? If not what are these files called ?

Last edited by i286; 12-29-2003 at 09:24 AM.
 
Old 12-29-2003, 09:40 AM   #5
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
I found the kernel-source rpm and tried to install it. Installation went about 50% and then some error and now if I try to install it again it says it's already installed and if I try to uninstall it says it needs libtk8.3.so to continue. What now should I reinstall fedora?

edit:
I'll create a new thread about this kernel thing.

Last edited by i286; 12-29-2003 at 10:51 AM.
 
Old 12-29-2003, 12:28 PM   #6
ts_sudarshan
LQ Newbie
 
Registered: Oct 2003
Location: Bangalore
Distribution: Arch, SUSE OSS
Posts: 23

Rep: Reputation: 15
nope. you don't need to reinstall fedora as of now... try:
rpm -qa |grep <kernel source name>
this will show whether the package by this name exits...
now, if it exists... rpm -e <kernel source name>
if it shows any dependency problem, then remove that package first...
also, you can type.. rpm -e <kernel source name> --nodeps
to ignore dependency issues. be WARNED that is Dangerous...
next, mount the cd that has the source rpm and then,
rpm -ivh <kernel source name>

next , after successful install of the kernel source, goto ctrl-alt-F1. there log in as root
next type -> init 3
now, press ctrl-alt-F7 to clarify that XServer is not running..
now.. if you have the default kernel provided by fedora, then type,
export CC=gcc32
//NOTE: without this installer may give error.. as there is GCC3.3 present in fedora and the default kernel has been compiled using GCC3.2
then,
./NVIDIA-Linux-x86-1.0-4496-pkg2.run
from the directory where the installer is there...
next.. modify the /etc/X11/XF86Config file to have
Driver "nvidia"
Option "nologo" //<NOTE>this is optional if you don't want NVidia logo
now, type.... init 5
your XServer should start...
ATB, keep posted with the results..
 
Old 12-29-2003, 02:20 PM   #7
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
O Y G !!!! IT ACTUALLY WORKS NOW I GET 2500 FPS WITH glxgears
Thank you! Thank you! Thank you!
But I still get
Xlib: extension "XFree86-DRI" missing on display ":0.0".
When I run that glxgears. Any idea what that means.

Was that bad luck or something to try Linux for first time just when nVidia released drivers that wont work with this without some strange tweaking. Almost gave up to the dark side.
Thank you for your help and if someone knows what that error means please share that information. This is so cool. I'll never get back to windows anymore !! Do you hear that billy I'LL NEVER GO BACK!!!
 
Old 12-29-2003, 02:31 PM   #8
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Running glxinfo shows that direct rendering is "no"
 
Old 12-29-2003, 02:50 PM   #9
i286
LQ Newbie
 
Registered: Dec 2003
Distribution: Fedora
Posts: 24

Original Poster
Rep: Reputation: 15
Ok getting quite good at this. Those old drivers needed remove of /usr/X11R6/lib/tls files. Now it works like a dream if dreams are something that work.
 
Old 12-30-2003, 10:57 AM   #10
ts_sudarshan
LQ Newbie
 
Registered: Oct 2003
Location: Bangalore
Distribution: Arch, SUSE OSS
Posts: 23

Rep: Reputation: 15
i286: Hope all the problems have been rectified. As far as this question is concerned,
Quote:
" But I still get
Xlib: extension "XFree86-DRI" missing on display ":0.0".
When I run that glxgears. Any idea what that means."

My guess is that it has something to do with the XF86Config file. See whether the option DRI has been hashed out..
# Load "dri"
For further details, check the documentation of the driver...
There is also a possibility to only extract the contents in the .run file of the driver.
./NVIDIA-Linux-x86-1.0-4496-pkg2.run --extract-only

NVIDIA-Linux-x86-1.0-4496-pkg2/usr/share/doc is the directory where the docs are present.. Read it to find more ATB
 
Old 01-04-2004, 12:45 PM   #11
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Debian Squeeze AMD64
Posts: 94

Rep: Reputation: 16
Hi all,

I have exactly the same problem, but I don't seem to be able to fix this.
I have downloaded version 5328 of the Nvidia displaydrivers. I also have a Gforce 4 440 MX video card. After installation of the driver and the configuration of the XFree86Config file, the NVidia logo does display. But when I start Tuxracer, it's really slow.

Further I have searched for GCC on my system, and there's a gcc32 in usr/bin. In the package list of the installation CD's it says also gcc3.2.3 instead of 3.3. My kernel version is: 2.4.22-1.2115.nptl.

I have the kernel source installed. I did this during the installation of Fedora. To install the NVidia drivers I did the following:
I pressed ctrl+alt+F1 and logged on as root.
Then typed "init 3" (without the quotes)
then typed "export CC=gcc32" and did an echo $CC to make sure it went right. It did.
after that is ran "sh NVIDIA-Linux-x86-1.0-5328-pkg2.run
When the installer completed I modified the XFree86 file. I commented "Load dri" out and changed "driver "nv"" in "driver "nvidia"".
After that I typed "init 5" and logged on to gnome. The nvidia logo did display.

Does someone have any tips for me?

 
Old 01-04-2004, 02:44 PM   #12
Falcon-0186
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware, Fedora
Posts: 4

Rep: Reputation: 0
Hello,

I have installed the nvidia driver and followed the configuration procedure (according to the instructions posted by ts_sudarshan) however, I am still having difficulty with the display. The screen modes available according to XF86Config are 1024x768 800x600 and 640x480. In Preferences > Screen Resolution, only 800x600 and 640x480 are available. Also, the full display is not being utilized. Any tips would be greatly appreciated. I am using Fedora Core on a Toshiba laptop (if that makes any diff).

Last edited by Falcon-0186; 01-04-2004 at 03:02 PM.
 
Old 01-04-2004, 03:02 PM   #13
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 45
i had disabled both "GLcore" and "dri" in the modules section of the xf86config-4 file.
 
Old 01-04-2004, 03:26 PM   #14
Falcon-0186
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware, Fedora
Posts: 4

Rep: Reputation: 0
glcore was not listed in the XF86Config file so I did not need to comment it out. I know the driver is being used because the nvidia logo appears and as a test, tux racer runs smoothly. I am sure there is something stupid that I have overlooked.
 
Old 01-05-2004, 08:05 AM   #15
Falcon-0186
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware, Fedora
Posts: 4

Rep: Reputation: 0
I got the display to utilize the entire screen by modifying the HorizSync (see below). However, now apps that require glx do not load. I get "extension GLX missing on display :0.0". Any ideas?

The HorizSync was default set to 48.5. I did:
# ctrl+alt+f1
# init 3
# <!-- modified xf86config to HorizSync 60.0 -->
# init 5
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA GeForce4 MX 420 TwinVeiw Problems standard.killer Linux - Hardware 2 10-11-2005 08:26 AM
[fedora c3]nvidia drivers h3xis Linux - Hardware 0 02-08-2005 05:36 PM
NVidia GeForce4 440MX Drivers? vi0lat0r Linux - Hardware 8 03-23-2004 08:03 PM
Fedora and Nvidia Drivers lucastic Fedora 16 11-16-2003 08:58 PM
Nvidia drivers on debian - GeForce4 jymden Linux - Hardware 4 03-23-2003 11:16 AM


All times are GMT -5. The time now is 07:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration