LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 09-27-2006, 11:49 PM   #1
spicyed
LQ Newbie
 
Registered: Jan 2006
Location: New Jersey
Distribution: Fedora Core 4, Slackware 10.2
Posts: 29

Rep: Reputation: 15
Problems with folder permissions, and truecrypt.


Hi,

I have an ftp server, and the drive which holds the data in ftp root is contained in a truecrypt volume. This drive is /dev/hda.

I mount this drive to where the ftp root is set to, let's call it /var/ftp/, using truecrypt

i run:

truecrypt /dev/hda /var/ftp

I enter the password, and the drive is mounted. All the files already on the drive can be accessed and downloaded by all on the ftpserver. However, only root has permission to write to this drive. Whether local or from ftp.

I figured that I would be able to chmod the device by "chmod -R a+rwx /var/ftp/" or chmod'ing new folders inside the mounted drive.

This does not give me write permissions as it should for the drive. Is there something that I am doing wrong, or could it be truecrypts fault for not allowing me to chmod the drive?
 
Old 09-28-2006, 04:40 AM   #2
mickyg
Member
 
Registered: Oct 2004
Location: UK
Distribution: Ubuntu/Kubuntu
Posts: 245

Rep: Reputation: 30
Have you looked at changing the mount options for the drive in /etc/fstab?? That way you won't need to chmod everytime the drive is mounted.
 
Old 09-28-2006, 11:31 AM   #3
spicyed
LQ Newbie
 
Registered: Jan 2006
Location: New Jersey
Distribution: Fedora Core 4, Slackware 10.2
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mickyg
Have you looked at changing the mount options for the drive in /etc/fstab?? That way you won't need to chmod everytime the drive is mounted.
Well the problem is not that I have to chmod, it's that I can't. Chmod has no effect, and also gives me no error.
 
Old 09-28-2006, 11:56 AM   #4
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 1,949

Rep: Reputation: 279Reputation: 279Reputation: 279
I would ask on the TrueCrypt forums. http://forums.truecrypt.org/ To get into the "Problems-Linux" or "Problems" subforums, you need to setup a userid. Not so for the "General" subforum. Not sure why that is. I did a quick search using my id on "write permissions" for the Problems-Linux subforum, and there were quite a few hits. I don't have the time at the moment to research through them all so I can't give you any definite answers, but I'm guessing you can find what you need in those forums.
 
Old 09-28-2006, 12:05 PM   #5
spicyed
LQ Newbie
 
Registered: Jan 2006
Location: New Jersey
Distribution: Fedora Core 4, Slackware 10.2
Posts: 29

Original Poster
Rep: Reputation: 15
http://forums.truecrypt.org/viewtopic.php?t=4150

I've already asked there, so far nothing. :-p

Thanks though.
 
Old 10-04-2006, 05:39 AM   #6
tolohosh
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Hi freinds,

I install fedora 5 in the second hard disk and windows xp in the first hard disk but i can't mount hda in the fedora and i see error PERMISSIONS DENIED.I enter in the root but I see same error again.Please help me.Here is my fstab

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

Last edited by tolohosh; 10-04-2006 at 02:03 PM.
 
Old 10-08-2006, 04:58 PM   #7
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 1,949

Rep: Reputation: 279Reputation: 279Reputation: 279
I just had another thought on this pop into my head (yeah, I know, about two weeks too late!)

Quote:
Originally Posted by spicyed
i run:

truecrypt /dev/hda /var/ftp
Did you try mounting the truecrypt volume with the -u option?

e.g.,
Code:
truecrypt -u /dev/hda /var/ftp
From the command "man truecrypt"
Code:
       -u, --user-mount

              Set default user and group ID of the filesystem being mounted to
              the user and group ID of the process which  executed  TrueCrypt.
              Some filesystems (like FAT) do not support user permissions and,
              therefore, it is necessary to supply a default user and group ID
              to the system when mounting such filesystems.

Last edited by haertig; 10-08-2006 at 04:59 PM.
 
Old 07-31-2008, 12:27 PM   #8
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
The solution is to use the truecrypt --fs-option. for example:
Code:
truecrypt --fs-option="uid=1000,gid=1000,umask=0002" file.tc mount-point/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems mounting Truecrypt volume in Suse 10 Leslie Mackeen Linux - Security 2 06-16-2006 01:23 PM
Folder Permissions HeReigns Linux - Networking 5 03-08-2006 03:36 AM
Having problems changing permissions on a folder zener Linux - Security 16 12-19-2005 09:32 AM
permissions difference between /home/..../folder and /root/folder darkleaf Linux - General 3 07-21-2005 05:23 PM
Folder permissions fatboyjim Linux - Newbie 12 06-05-2002 02:20 PM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration