LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 10-29-2002, 08:26 PM   #1
Gentooer
LQ Newbie
 
Registered: Oct 2002
Location: Au
Distribution: Gentoo 1.2
Posts: 2

Rep: Reputation: 0
problems with a fresh Gentoo 1.2 install


I recently re-installed a fresh copy of Gentoo 1.2. The install went fine and my system was up and running. I sshd'd into the box from my Windows machine and started updating all the packages. I did an 'emerge -u world' after checking what was going to be installed and off it went. Half way through emerging all the new packages my windows machine reset (gah!). I then tried restarting the 'emerge -u world' on the machine locally and it seemed to finish fine. When I then tried to log into the box locally I kept getting all these weird error messages popping up:

Quote:
configuration error - unknown item 'CONSOLE' (notify administrator)
configuration error - unknown item 'CREATE_HOME' (notify administrator)
configuration error - unknown item 'DIALUPS_CHECK_ENAB' (notify administrator)
configuration error - unknown item 'ENVIRON_FILE' (notify administrator)
configuration error - unknown item 'ENV_HZ' (notify administrator)
configuration error - unknown item 'ERASECHAR' (notify administrator)
configuration error - unknown item 'KILLCHAR' (notify administrator)
configuration error - unknown item 'LOG_OK_LOGINS' (notify administrator)
configuration error - unknown item 'MAIL_CHECK_ENAB' (notify administrator)
configuration error - unknown item 'mAIL_DIR' (notify administrator)
configuration error - unknown item 'NOLOGINS_FILE' (notify administrator)
configuration error - unknown item 'PORTTIME_CHECKS_ENAB' (notify administrator)
configuration error - unknown item 'QUOTAS_ENAB' (notify administrator)
configuration error - unknown item 'SU_NAME' (notify administrator)
configuration error - unknown item 'SU_WHEEL_ONLY' (notify administrator)
configuration error - unknown item 'SYSLOG_SG_ENAB' (notify administrator)
configuration error - unknown item 'SYSLOG_SU_ENAB' (notify administrator)
This happens with all users and only seems to be when I log in locally. If I ssh into my box I dont get the errors.

I have noe redone the install and re-updated all my world packages and the exact same problem appeared.

Here are the packages associated with my 'world':

Quote:
ExtUtils-MakeMaker-6.05.tar.gz
man-1.5k.tar.gz
Linux-PAM-0.75.tar.gz
man-pages-1.52.tar.bz2
Python-2.2.2.tgz
metalog-0.6.tar.gz
autoconf-2.13.tar.gz
miscfiles-1.3.tar.gz
autoconf-2.54.tar.bz2
modutils-2.4.19.tar.bz2
automake-1.4-p5.tar.gz
nano-1.0.9.tar.gz
automake-1.5.tar.gz
ncompress-4.2.4.tar.gz
automake-1.6.3.tar.gz
ncurses-5.2.tar.gz
bash-2.05a.tar.gz
net-tools-1.60.tar.bz2
bison-1.35.tar.gz
openssh-3.5p1.tar.gz
bzip2-1.0.2.tar.gz
openssl-0.9.6g.tar.gz
cracklib2_2.7.orig.tar.gz
pam-0.75-r10-gentoo.tbz2
db-3.2.9.tar.gz
pam_login-3.7.tar.bz2
debianutils_1.16.3.tar.gz
patches-2.4.19-gentoo-r10.tar.bz2
devfsd-v1.3.25.tar.gz
pcre-3.9.tar.bz2
diffutils-2.8.4.tar.gz
perl-5.6.1.tar.gz
e2fsprogs-1.29.tar.gz
procps-2.0.10.tar.bz2
expat-1.95.4.tar.gz
pwdb-0.61.tar.gz
file-3.39.tar.gz
readline-4.1.tar.gz
fileutils-4.1.11.tar.gz
reiserfsprogs-3.6.4.tar.gz
flex-2.5.22.tar.gz
rsync-2.5.5.tar.gz
gawk-3.1.1.tar.gz
sed-4.0.tar.gz
gcc-2.95.3.tar.gz
sh-utils-2.0.15.tar.gz
gettext-0.11.5.tar.gz
shadow-4.0.3.tar.gz
glib-1.2.10.tar.gz
ssmtp-2.38.14.tar.gz
glibc-2.2.5.tar.bz2
sysvinit-2.84.tar.gz
glibc-linuxthreads-2.2.5.tar.bz2
tar-1.13.25.tar.gz
groff-1.17.2.tar.gz
texinfo-4.2b.tar.gz
gzip-1.3.3.tar.gz
textutils-2.1.tar.gz
hdparm-5.2.tar.gz
util-linux-2.11r.patch.gz
iptables-1.2.7a.tar.bz2
util-linux-2.11w.tar.gz
less-378.tar.gz
vixie-cron-3.0.1.tar.bz2
libtool-1.4.1.tar.gz
wget-1.8.2.tar.gz
linux-2.4.19.tar.bz2
wget-new-percentage-cvs-20011209.tar.gz
make-3.80.tar.gz
which-2.14.tar.gz
Does anyone have any idea which package is causing this problem, or possibly what I coudl do to resolve the problem?
 
Old 12-16-2002, 10:39 AM   #2
TheNine
LQ Newbie
 
Registered: Dec 2002
Distribution: Gentoo
Posts: 1

Rep: Reputation: 0
Hey Gentooer,

I dunno if you're still at this point or whether you've done something else by now, but I've just myself overcome this problem. Here's the story:

When you downloaded and installed the newer version of the login program, gentoo's portage didn't put the new style config file in the correct location - it saved your old one thinking it would avoid errors. The old file is /etc/login.defs. The new one will have been called something like ._cfg0000_login.defs. Replace your old file with the new one, and the problem disappears instantly

Hope this wasn't too late to not be helpful - I know what it's like to suddenly find your entire system unusable!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub not booting with Sata on fresh Gentoo install jxbryan Linux - Software 2 03-08-2005 06:02 PM
fresh gentoo install, not recognizing eth0 CamelofCamelot Linux - Networking 4 02-13-2005 05:21 PM
[GENTOO] fresh install, two nasty problems giro83 Linux - General 2 09-03-2004 12:59 AM
Problems booting a fresh gentoo install on onboard sata stoned Linux - Distributions 3 08-29-2004 05:43 AM
Gentoo Grub Error (Fresh Install) dkaplowitz Linux - Distributions 6 11-21-2003 02:55 PM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration