LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-13-2004, 11:35 PM   #1
Toshi3
LQ Newbie
 
Registered: May 2004
Distribution: Red Hat 9
Posts: 20

Rep: Reputation: 0
Problems w/ manually add. a driver at install. time


Hi everyone,

I trying to PXE install a couple of dual Opteron machines with SATA hard drives that connect to a Silicon Image 3114 controller on the board. This controller is not supported by any kernel out of the box (2.4.21-15.ELsmp and 2.4.21-15.EL in my case), but I have precompiled drivers for these two kernels. The problem is that the SATA drive is the only drive in the box...

Question I: Does anyone have a suggestion how to include these drivers in PXE install w/o attaching a floppy/CD to the local machine?

I attached a floppy drive and when the installation program prompts "No hard drives found...." I opened a console (ctrl+alt+f2), manually insmod + mknod, switched back to the installation program and finished the installation. But the drivers weren't included in what was installed on the hard drive......

Question 2: If I open console like I did, what should I do to load the modules "permanently"? so that they are included in the installed copy (both for the SMP kernel and the single cpu kernel) - equivalent to using a driver disk I think.

By the way, the installation program doesn't ask for a driver disk as I'm using a modified version of anaconda (otherwise this should been easy, no?!?).

I would greatly appreciate any advice.

Thank you,

Toshi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to add a device driver into custom redhat 9 install cd zhchang Linux - Hardware 3 03-31-2010 02:57 AM
How do you manually install Nvidia driver? Micro420 Suse/Novell 2 09-24-2005 04:57 AM
providing driver during install time jomy Linux - Hardware 0 12-29-2004 03:21 AM
Manually Reconnecting all the time - what gives...? perry Linux - Networking 1 11-15-2003 06:45 PM
how do you add/remove Gnome menu entries manually? randomx Linux - General 2 10-16-2003 10:06 PM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration