LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-01-2010, 04:02 PM   #16
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51

Hey,

It appears the nouveau driver is still loading which will cause the issue your having. You can see this by looking at you lsmod output:
Code:
Module                  Size  Used by
nls_cp437               4919  1 
isofs                  29250  1 
udf                    78785  0 
crc_itu_t               1371  1 udf
aes_i586                7268  0 
aes_generic            26863  1 aes_i586
nouveau               467048  0 
So, after you edited grub did you run the updates? You would update grub like this
Code:
sudo update-grub
THEN you need to update your init with
Code:
sudo update-initramfs
Then reboot.

This has worked on my ubuntu 10.04 system. However, you can also try the following:

Even though nouveau ( this is a open source nvidia driver with out acceleration ) shows in lsmod, try to unload it manually to see what it kicks back. So, run this:
Code:
sudo modprobe -r nouveau
IF that tells you nouveau is in use then you'll need to blacklist another way.

Blacklist modules the roundabout way:
  1. Add the modules to blacklist to the video modules list in modprob.d with
    Code:
     sudo nano /etc/modprobe.d/nvidia-graphics-drivers.conf
    and add
    blacklist nouveau
    blacklist lbm-nouveau

  2. Double check that your /etc/default/grub entry is correct.
  3. Rebuild / update grub and initramfs (make this your last step).
  4. reboot

The /etc/modprobe.d/nvidia-graphics-drivers.conf is where the ubuntu scripts place blacklist info for video drivers. You can also add those entries to /etc/modprobe.d/blacklist ( you can look at all the files by running ls, you know that though i guess ). After you reboot check your System>Administration>Hardware Drivers to see if nvidia-current is active.you can also try to change your resolution with the nvidia control applet listed in System>Administration>Nvidia . Hope it works.

Just a side note: try running
Code:
sudo apt-get dist-upgrade
( if you installed from the beta iso for 10.04 then it will update a few things to the 10.04 LTS release ).

Also, post the output of
Code:
aplay -l
Just take note: ANY CHANGES MADE TO THE GRUB.CONF FILE WILL NOT TAKE UNTIL YOU RUN
Code:
sudo update-grub && sudo update-initramfs

Last edited by mrmnemo; 08-01-2010 at 05:46 PM.
 
Old 08-01-2010, 09:22 PM   #17
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Hi,

Morning. I was up but didn't notice this had gone to the 2nd page! Well, I had done everything as above - but I will carefully redo the same once again. The only thing I can remember is : While giving this single line command :
Quote:
sudo update-grub && sudo update-initramfs && sudo apt-get update && sudo apt-get upgrade
..... there was an error - mentioning that "option has to be specified" - so I had opted for "all"

Anyway, let me go through the process once again.

(Remember, as of now, it is working fine - we are just trying to fix the resolution - and/or, the sound problem)

Rest everything is working fine - in fact, I am logged on to the same system.
 
Old 08-01-2010, 09:50 PM   #18
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
oopps!! run it this way
Code:
sudo update-grub && update-initramfs -u
Sorry about that!! All should have been ok. Either way, the blacklisting is gonna be important for you. In your case nouveau is beating your nvidia ACCELERATED driver during the boot process.

Last edited by mrmnemo; 08-01-2010 at 09:52 PM.
 
Old 08-01-2010, 11:44 PM   #19
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Your are right. nouveau is still beating the nvidia. I went through the whole process, twice over - without any error - yet the resolution is 1280x720 - and nvidia not in use.

Let me list out the process, once again - with some output also for your benefit - and tell me where I missed out.

1)Befoare we started out, recollect there was only a blank screen.
2)Then, I changed the 'ro quiet splash' with 'nosplash nomodeset, - and lo it worked.

Then we started the process of activating the 'nvidia driver' by :

3) Edited the grub file (/etc/default/grub) to add the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash blacklist=nouveau"
(There was no 'defaults' directory - but the file was in the directory 'default')
4) Updated grub - (sudo update-grub) - (Deviation - I used gedit to edit the file)
5) Updated initramfs - (sudo update-initramfs -u)
6) Updated file - (sudo apt-get update - (Last 3 lines of output)
Quote:
Fetched 3,803B in 6s (584B/s)
Reading package lists... Done
cr@cr-laptop:~$
7) Upgraded file apt-get - (sudo apt-get upgrade) - the output :
Quote:
cr@cr-laptop:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
cr@cr-laptop:~$
8) Installed the driver (sudo apt-get install nvidia-current -y) - about 23 mb downloaded.
9) Rebooted
10) Everything normal. Except the resolution is '1280x720' instead of what it should be - '1366x768'

Since then - have tried out and re-run the whole sequence - without any change.

Now, as requested, the output of 'aplay -l'

Quote:
cr@cr-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
cr@cr-laptop:~$
Can you spot any goof up in the above order?

Regards.

Last edited by cr4321; 08-01-2010 at 11:52 PM.
 
Old 08-02-2010, 12:50 AM   #20
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
One serious doubt : -

There is no xorg.conf file in /etc/X11
Instead, there are many similar files like :
Quote:
xorg.conf.failsafe
xorg.conf-backup
xorg.conf-backup-100731192306
xorg.conf-backup-100801122347
xorg.conf-backup-100802094120
Could this be a problem?

Last edited by cr4321; 08-02-2010 at 01:02 AM.
 
Old 08-02-2010, 01:00 AM   #21
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
ok, as to your sound...may be a fix for it.
As to your video issue...your getting the hang of things fast huh?!!
So, since nouveau was loading and borking the nvidia module...check and see if it is still loaded now. It should not be. Assuming the blacklist held for nouveau, you will have to enable the nvidia- current driver in the system.>admin.>hardware drivers THEN IF you had to enable the driver, you will have to reboot yet again. after the reboot, you can turn on visual effects and/or change the resolution via the NVIDIA control applet located at system>admin>nvidia x server settings.

As a side, you can run
Code:
 nvidia-xconfig
which will build your xorg stuff again. but you do have it or you wouldnt be using a gui at all. it would fault out on boot. but try the above. the only thing stopping your resolution at this point is going to be that noveua module. However, go ahead and run nvidia-xconfig , make sure nouveau is indeed NOT loading, make sure you activated nvidia current then reboot, then check nvidia x server control!

let me know how it goes.
 
Old 08-02-2010, 01:01 AM   #22
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
your name wouldnt be chris would it?
 
Old 08-02-2010, 01:19 AM   #23
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
here is how i have nouveau blacklisted:

Code:
cat /etc/modprobe.d/nvidia-graphics-drivers.conf 
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
and on the sound issue, edit /etc/modprobe.d/alsa-base.conf ( edit yours to add the highlighted text only AFTER you make a back up):
Code:
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel model=sony-assamd
Everything outside of the highlight is not specific to your machine, but mine. I just posted it to let you see what it would look like.

If any thing on your sound changes for the worse then you can just revert to your back-up.

Last edited by mrmnemo; 08-02-2010 at 01:31 AM.
 
Old 08-02-2010, 01:43 AM   #24
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
check back in the morning.
 
Old 08-02-2010, 01:51 AM   #25
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Hi there

(now I am back on the desktop - because, the laptop is acting up!!)

To answer your query, your guess is wrong - My name is Ramachandran - and I am in India. (known as "cr" to friends)

Back to the laptop - problem :

After I did the 'nvidia-xconfig' it did create the 'xorg.conf' file but on reboot the screen has split into two horizontally - sort of a wrap around from the centre of the screen!! I think we are somewhere close to licking the problem.. I will try out something there with instructions that I can read here on my desktop.

Hope, it's not too late in whichever timezone you are in.

Thanks for all your efforts - it's nice working together.

Regards.
 
Old 08-02-2010, 02:31 AM   #26
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
wha??? your screen split? man...I feel bad now. I do need to get some sleep. I will help you some more in the morning. it is sounding like your monitor is not being seen correctly though ( obvious ..i know ). I had a similar issue but it was on a hdtv. try and post your fixes. if need be we can get you back to one of the restored xorg. files via a session with out x. see ya in the morning.
 
Old 08-02-2010, 02:49 AM   #27
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Hi,

Not to feel bad at all. Now I am in a position to come out of these situations. That's the learning I had so far, thanks to you! I am now back at the lap-top - albeit in low resolution mode. In similar situations, earlier - I did a re-installation!
So, there's a lot of good work also done...

Now the sound has improved tremendously... the laptop has cleared it's throat, seems like!!!

Of course, still the nvidia drivers are not loading. It shows as activated - but not in use.

We will lick that too ... no hurry. Have a good nights sleep - and things will be better for sure.

Good night.
 
Old 08-02-2010, 09:03 PM   #28
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Want me to try out anything new?

Meanwhile, I have just installed Fedora13 and also SUSE in other partitions, Both are working in 1366x768 resolution, and did not have any problem with the drivers. In both though, it does not recognize the monitor as Sony.

Regards.
 
Old 08-02-2010, 10:19 PM   #29
mrmnemo
Member
 
Registered: Aug 2009
Distribution: linux
Posts: 527

Rep: Reputation: 51
if you could please log into the ubuntu partition and hit
ctrl+alt+f1

then run :
Code:
 xdpyinfo  | grep 'dimensions:' > /home/$USER/Desktop/xreslution.txt
(i want to see what resolution x thinks its supposed to run at)

then run :
Code:
sudo rm /etc/X11/xorg.conf && sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf && sudo /etc/init.d/gdm restart && sudo reboot
That should at least get the functioning desktop back.
Save that to your home folder for later. I would like to see what your seeing.

Also, so your sound works the way it should now? All jacks work (mic, headphones, any volume buttons on your keyboard)?

Last edited by mrmnemo; 08-02-2010 at 10:25 PM.
 
Old 08-03-2010, 12:44 AM   #30
cr4321
Member
 
Registered: Aug 2009
Posts: 41

Original Poster
Rep: Reputation: 15
Hello, how are you?

Yes, now I have got back the laptop to low resolution (1280x720)
and the the xdpy command gives : dimensions: 1280x720 pixels (339x191 millimeters)

The sound is also ok, rythmbox is playing fine. I haven't tried other stuff - but should be fine.
Regards.
 
  


Reply

Tags
display, sony, vaio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony Vaio + Ubuntu + Nvidia cr4321 Linux - Laptop and Netbook 5 08-05-2010 04:37 AM
Sony-Vaio-Intel Cantiga Integrated Graphics Drivers brokenmaize Linux - Hardware 3 08-01-2009 02:50 PM
Finding audio drivers for Sony Vaio computers zachmad Linux - Newbie 1 03-21-2009 09:51 PM
drivers for motion eye webcam on sony vaio fz27g vineet7kumar Solaris / OpenSolaris 1 11-22-2007 05:21 PM
LAN drivers on Slack 11 not working (Sony VAIO) whitesnake190684 Linux - Hardware 5 07-19-2007 01:51 AM


All times are GMT -5. The time now is 12:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration