LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-26-2004, 03:46 AM   #1
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Rep: Reputation: 15
Problem with special chars in general


Hi there!

I've got the following problem:

Was working on a php script, and noticed, that in a string, the ZDE (Zend Development Environment) didn't proper display chars like "" and "", and so on... Thought it was a config problem in ZDE itself, but it isn't... got the same problem while surfing e.g. with lynx....

The php script was previously saved under Windows, and displayed well in Zend and on the web page as well.... after saving under Linux, the special chars misbehaved....


How can I setup this, so that special chars will be well displayed? Pretty sure, that it has something to do with "encoding" standard, but where to change this??


As it seems to be a general system problem, can anyone help me please?



smokylux
 
Old 05-26-2004, 03:53 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
In the past emacs has proved to be quite clever in
resolving such issues for me via its mule-environment.

Load buffer, emacs usually does a great job at picking
up the encoding used, select save buffer as from mule,
and voila! :)



Cheers,
Tink
 
Old 05-26-2004, 04:08 AM   #3
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Original Poster
Rep: Reputation: 15
Thx!

That will be a solution for "correcting" scripts that should already be up and running.... that doesn't solve my general display problem.... e.g. while surfing with lynx... Noticed the problem in Mozilla too.... not quite as bad as in lynx, but still many special chars aren't displayed!

But it's a good start


Any idea on how to change the system-wide encoding, so that I won't have to open emacs for all my scripts written before?



smokylux
 
Old 05-26-2004, 04:10 AM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
What's your locale set to?

I have LC_ALL=POSIX ;)


Cheers,
Tink
 
Old 05-26-2004, 04:21 AM   #5
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Original Poster
Rep: Reputation: 15
Hmmmm, as I'm pretty much a newbie to Linux, can you explain me please, where exactly I can find this setting?


Thx!
 
Old 05-26-2004, 04:32 AM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,965
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Open a shell ... type

env | grep LC_


Cheers,
Tink
 
Old 05-26-2004, 04:46 AM   #7
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Original Poster
Rep: Reputation: 15
That gives me no output at all....

just entering "env" I got somewhere the line: LANG=en_US.ISO-8859-1 but nothing with LC_

Note: Just changed my /etc/sysconfig/i18n file and replaced en_US.UTF-8 with en_US.ISO-8859-1 as system language, before typing env... This would be Western European encoding wouldn'it?

Is there something wrong with the syntax? (means: is it ISO... or iso...)

Do I have to reboot for changes to have effect?


Is this the right thing to do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Special characters problem MartinZ Suse/Novell 5 07-12-2011 09:21 PM
block special and character special files s_shenbaga Linux - Newbie 1 04-20-2005 03:49 PM
German umlaute (special chars) in file system steltner Linux - General 5 10-27-2003 02:07 PM
telnet and special chars csDraco_ Slackware 7 05-21-2003 09:57 AM
Ximian crashes when I enter "special chars" into message borbjo Linux - Software 0 01-28-2003 07:31 AM


All times are GMT -5. The time now is 02:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration