LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-10-2004, 07:21 AM   #1
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Rep: Reputation: 30
problem with mounting usbdevfs to /proc/bus/usb


i've installed Debian 3.0r2 Woody. now i'd like to configure my internet connection. i've compiled ppp, usb and usb-uhci into kernel as modules after that i've compiled and installed modem drivers. i can also insert them into kernel with no errors, but the problem appears, when i want to synchronize the modem with my phone line (i'm talking about ADSL). i was told to add the following lines into /etc/fstab:

none /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0

and so i did. while booting the system no errors are reported, but there is no /proc/bus/usb directory in which usbdevf should mount itself. as far as i know i cannot create that directory. what should i do to mount usbdevfs there.
 
Old 01-10-2004, 07:49 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
You might want to load the usb modules in order for the entries in /proc to exist. Use modprobe usb-uhci and so on to load all the required modules and then check back to see if your /proc/bus/usb exists.

I don't really recall how it works but you may also have to attach the USB device for the usb bus will show up in /proc.

Håkan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
where is /proc/bus/usb/devices???? mrchaos Linux - Software 4 12-04-2005 10:26 PM
/proc/bus/usb problem arunka Linux - Hardware 0 11-07-2005 06:54 AM
MDK 10.2: No USB at all (/proc/bus/usb/devices missing) shrodi Mandriva 5 07-01-2005 11:28 AM
No USB at all (/proc/bus/usb/devices missing) shrodi Linux - Hardware 1 05-26-2005 04:07 AM
/proc/bus/usb busy Commish66 Linux - General 2 09-18-2003 05:42 PM


All times are GMT -5. The time now is 03:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration