LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-17-2012, 03:34 AM   #1
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,026

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Problem with individual locale setting


Hi there,

on my desktop PC I'm running Linux Mint 12 (Lisa) using the MATE desktop. The system's locale is basically en_US.utf8. For a long time, I had the assignment

Code:
LC_COLLATE="C"
in my /etc/default/locale file, which worked fine: In most applications, including the Caja file manager (successor of Nautilus), items were now sorted the way I would expect, that is, according to their character code and nothing else.

Now recently I decided to add

Code:
LC_TIME="en_DK.utf8"
which would -according to many posts across the internet- make the system use the ISO format for dates (YYYY-MM-DD).

Now I see that the date format is what I want it to be; however, the sort order reverted to the original weird order, not the "pure" C sorting any more. When I issue a 'locale' command, it displays:

Code:
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME=en_DK.utf8
LC_COLLATE=en_US.UTF-8
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Obviously, adding the LC_TIME line in /etc/default/locale makes my system ignore the LC_COLLATE. The order of these two lines doesn't make a difference (hadn't expected one, though).

What's happening here? What am I doing wrong? All I want is to have LC_COLLATE="C" and LC_TIME="en_DK.utf8" effective at the same time.

Thank in advance for any helpful hint.

[X] Doc CPU
 
Old 09-01-2012, 09:04 AM   #2
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,026

Original Poster
Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Hi there,

Quote:
Originally Posted by Doc CPU View Post
What's happening here? What am I doing wrong? All I want is to have LC_COLLATE="C" and LC_TIME="en_DK.utf8" effective at the same time.
two weeks have passed, and nobody's been able to give a clue. What a pity.
I'm not putting any of you under pressure, am I? ;-)

Well, I still haven't any idea what's going wrong on this particular PC. However, I have some additional information.
I tried to set up the same locale configuration on two systems running Mint 13 (Maya), and it works as expected there.
I tried the same on another system running Mint 12 (Lisa), and it worked on that system, too.

So obviously there's some misconfiguration on my main system that causes the silent conflict between LC_COLLATE="C" and LC_TIME="en_DK.UTF-8", but I can't pinpoint what it is. Besides, I can't make out where that weird LANGUAGE=en_US:en in the output of locale comes from, nor what it means (especially the colon). I'm also confused that some variables that locale displays are in quotes, and some are not. Maybe that's not meaningful, but it seems strange anyway.

[X] Doc CPU
 
  


Reply

Tags
lc_collate, lc_time, locale


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
[SOLVED] problem with setting locale konzo Linux - Newbie 1 01-23-2010 05:55 AM
locale setting, problem with en_US.UTF-8 pru Linux - Software 4 04-18-2008 04:07 AM
Strange locale setting problem _Lukes Linux - Newbie 2 12-05-2006 06:14 AM
"perl: warning: Setting locale failed." System wide problem Darek84CJ Debian 3 01-25-2006 05:22 PM


All times are GMT -5. The time now is 12:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration