LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-07-2005, 05:42 PM   #1
Slalomsk8er
LQ Newbie
 
Registered: Jan 2005
Location: Basel CH
Distribution: Gentoo
Posts: 12

Rep: Reputation: 0
Problem with Grub SATA and WinXP


I have the same problem like in http://www.linuxquestions.org/questi...14#post1395114 this tread.

I found the above with the search and think it fitts better in here.

To recapitulate the whole thing:

/dev/hda is Gentoo or linux in general
/dev/sda is WinXP

Mainboard is a ASUS A7N8X deluxe v. 2.0

I can boot WinXP, if I change the boot order in my BIOS!

Grub do not want to boot the XP, regardless of my config.

Grub showed some wired behavior, like print the WinXP config part and not react on pressing Ctrl + Alt + Delete.
An other time it showed a error like file system type x??(some hex stuff) not what i like (for other peaple this was coused by formating with a corrupt version of diskdruid i think, I never used this tool).
Last but not least, some thing like grub loading stage 1.5 and then nothing!?


Grub config is like this (at the moment):
Code:
map (hd0) (hd1)
map (hd1) (hd0)
chainloader (hd1,0) +1
Thanks, Dominik Riva

Last edited by Slalomsk8er; 01-08-2005 at 11:21 AM.
 
Old 01-08-2005, 11:25 AM   #2
Slalomsk8er
LQ Newbie
 
Registered: Jan 2005
Location: Basel CH
Distribution: Gentoo
Posts: 12

Original Poster
Rep: Reputation: 0
I checked my Grub device.map and hd1 is /dev/sda,
so to state it in the device.map brings nothing for me, as it is in there right now.

Next thing I do is look for a newer BIOS.

Thanks, Dominik
 
Old 01-14-2005, 05:00 AM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
I have done a reply to your linked file

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB problem with SATA adamski2000 Linux - Software 2 07-06-2005 04:52 AM
Easy Fedora/WinXP GRUB problem for the eggheads! krashd Linux - Newbie 4 12-09-2004 10:22 AM
Yet another SUSE9.1 and WinXP GRUB boot problem wellmt Linux - Newbie 7 05-23-2004 03:49 PM
Boot WinXP (on SATA) from GRUB (on PATA?) sbixby Linux - Newbie 3 04-30-2004 10:40 AM
i got RH8 & WinXP installed and properly working by GRUB. how can i reinstall WINXP? kublador Linux - Newbie 4 06-23-2003 12:00 PM


All times are GMT -5. The time now is 01:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration