LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Problem using Curl (http://www.linuxquestions.org/questions/linux-general-1/problem-using-curl-628592/)

srihariv 03-17-2008 03:35 AM

Problem using Curl
 
hello all,

I am using curl to access a https web server...

and i am seeing the following error.

curl: (77) error setting certificate verify locations:
CAfile: /usr/local/share/curl/curl-ca-bundle.crt
CApath: none

My requirement is to use https without client side authentication.. So i guess i need not send any certificates in my curl command. I need Only "Server Side Certification"..

Suppose if i give curl -k https://site/ , then i am able to access, but -k or --insecure i guess it will not be a secure transfer.

Can anyone help me on this.

~Srihari

whitemice 03-17-2008 05:22 AM

Quote:

Originally Posted by srihariv (Post 3091062)
hello all,
I am using curl to access a https web server...
and i am seeing the following error
curl: (77) error setting certificate verify locations:
CAfile: /usr/local/share/curl/curl-ca-bundle.crt
CApath: none
My requirement is to use https without client side authentication.. So i guess i need not send any certificates in my curl command. I need Only "Server Side Certification"..
Suppose if i give curl -k https://site/ , then i am able to access, but -k or --insecure i guess it will not be a secure transfer.
Can anyone help me on this.
~Srihari

"-k" isn't neccessarily insecure, encryption is still used but the certificate isn't verfied; I assume from the above error that you are using a self-signed certificate. Either that or your using a crap distribution (Gentoo? Slackware?) because I've *never* seen a CA search path of /usr/local/share/curl/curl-ca-bundle.crt. The CA search path should be where your distribution (/etc/ssl/certs for suSE/openSuSE). Or you can tell curl where your signing-authority certificates are stored with the --cacert / --capath options.

srihariv 03-17-2008 06:53 AM

@whitemice,

I have a weird error while configuring curl.. I have given the following option ./configure --with-ssl=/usr/bin/ssl ... Bu my results show that curl was configured without ssl ...

Can you just help me out on this..

I have also export PKG_CONFIG_PATH=/usr/local/ssl/lib/pkgconfig/

So can please help configuring curl with openssl... I have researched quite a few forums but without much help...

~Srihari.


All times are GMT -5. The time now is 03:21 AM.