LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-20-2003, 08:36 AM   #1
sattath
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
problem switching to a virtual terminal


hey,

i have a problem switching to a virtual terminal using ctrl+alt+f(1-12). when i try, nothing happens.

it worked a while ago, and i don't know what gone wrong.

what can be the reason for the problem? what configuration files?

I use mandrake 9.1 with kde (although i tried the same thing under gnome and the same problem occurs).

thanks, Or.
(and sorry for my bad English)
 
Old 10-21-2003, 07:49 AM   #2
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
Try typing "chvt 1" in a konsole window. This should have the same effect as CTRL+ALT+F1 should. If this works, try using CTRL+ALT+F2, etc. If these work then it is a problem with your XWindows configuration. The configuration file to look at is /etc/X11/XF86Config-4. I remember seeing some option like this at some stage in the past however can't remember what is was called. It should be near the top of the file and have a name like DontChangeVT. If you see something that looks likely, prefix it with a # to comment it out. Rebooting should put the new settings into effect.
 
Old 10-21-2003, 01:32 PM   #3
sattath
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks nhs!!

it works using the "chvt 1" when i'm logged as root (strange, isn't it?), and when i'm on another console, other then kde, i'm capable again using the ctrl+alt+fX. i don't know why when i'm on the seventh vt i can't do it.

thanks again, Or.
 
Old 10-22-2003, 07:21 AM   #4
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
Try commenting out the line DontChangeVT in XF86Config-4. Also try setting chvt to be SUID root in case XWindows uses it to perform switching (I'm guessing here).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual terminal problem under kernel2.6.7 expander Linux - General 2 07-07-2004 02:59 PM
X Windows Freezes when switching back from virtual terminal topace Linux - Software 0 07-01-2004 09:58 AM
Slackware Virtual Terminal Problem jon1591 Slackware 4 03-02-2004 12:01 PM
Virtual terminal switching? adamjaskie Linux - General 4 02-07-2004 09:30 PM
problem switching to a virtual terminal sattath Linux - Newbie 2 10-19-2003 05:43 PM


All times are GMT -5. The time now is 05:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration