LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 09-27-2006, 07:20 AM   #1
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Problem mounting DVD/CDs


When I put a DVD/CD into the computer, the KDE Daemon appears with whatever options depending on the the media on the DVD/CD. However if I choose Do Nothing or close the dialog box without choosing an option, then the DVD/CD does not mount.

How can I get the DVD/CD to mount even if I don't choose an option in the KDE daemon. Or can I add an option to just mount the DVD/CD to the KDE Daemon with having konqueror or the media play?

KDE v3.5.4-6.1 and FC5
 
Old 09-27-2006, 11:07 AM   #2
dongle911
LQ Newbie
 
Registered: Sep 2006
Location: Italy
Distribution: Kanotix (Debian-sid based distro) with kernel 2.6.18.1 and KDE 3.5.5
Posts: 2

Rep: Reputation: 0
Lightbulb automount cd/dvd

I had a similar problem with my Kanotix distro and I have solved by using this script (saved as automount_errorfix.sh) and launched once by KDE Konsole with: 'sh automount_errorfix.sh'
(If you're not root user, first type 'su' then 'root password')

automount_errorfix.sh script:

#!/bin/sh
grep -v cdrom /etc/fstab > /etc/fstab.new
# Add cdrom devices to /etc/fstab
for c in $(ls -d /dev/cdrom* 2>/dev/null); do
m=${c#/dev}
[ "$m" == "/cdrom" ] && m="/cdrom0"
[ -d /media$m ] || mkdir -p /media$m
printf "%-15s %-15s %-7s %-15s %-7s %s\n" "/dev/$(readlink $c)" "/media$m" "udf,iso9660" "user,noauto" "0" "0" >> /etc/fstab.new
done
mv -f /etc/fstab /etc/fstab.old
mv /etc/fstab.new /etc/fstab




Quote:
Originally Posted by Jongi
When I put a DVD/CD into the computer, the KDE Daemon appears with whatever options depending on the the media on the DVD/CD. However if I choose Do Nothing or close the dialog box without choosing an option, then the DVD/CD does not mount.

How can I get the DVD/CD to mount even if I don't choose an option in the KDE daemon. Or can I add an option to just mount the DVD/CD to the KDE Daemon with having konqueror or the media play?

KDE v3.5.4-6.1 and FC5
 
Old 09-27-2006, 12:11 PM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Remove the pmount program or make it unexecutable if you want to avoid "dynamic" mounting. You can always put your mountable devices in fstab and mount them with a click if you want (by creating shortcuts in the KDE desktop).

Last edited by vharishankar; 09-27-2006 at 12:12 PM.
 
Old 09-27-2006, 03:31 PM   #4
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Thing is I'm pretty sure I was able to just choose Do Nothing or close the Daemon and the DVD/CD would still mount. I suspect this was caused by a KDEupdate.

dongle if I add that to ~/.kde/Autostart how can I get it to start with a sudo?
 
Old 09-27-2006, 03:57 PM   #5
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
What I've done I've added an option in the KDE Daemon called Mount and which has no command. The only issue with that is that it comes up with an error message along the lines of a file was expected or something.
 
Old 09-27-2006, 08:59 PM   #6
dongle911
LQ Newbie
 
Registered: Sep 2006
Location: Italy
Distribution: Kanotix (Debian-sid based distro) with kernel 2.6.18.1 and KDE 3.5.5
Posts: 2

Rep: Reputation: 0
automount_errorfix.sh script

You don't need to insert the script in Autostart. Simply run it (sh automount_errorfix.sh) once with root rights. You'll obtain that each time a cd/dvd is inserted the drive will be automounted and a konqueror's window with cd/dvd content will be showed. You'll don't need to run the script again. That's all.


Quote:
Originally Posted by Jongi
Thing is I'm pretty sure I was able to just choose Do Nothing or close the Daemon and the DVD/CD would still mount. I suspect this was caused by a KDEupdate.

dongle if I add that to ~/.kde/Autostart how can I get it to start with a sudo?
 
  


Reply

Tags
cd, daemon, dvd, kde, mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem mounting video and audio CDs on FC3 vineet7kumar Linux - Newbie 5 09-14-2005 07:23 AM
DVD Problem. Won't read DVDs. Only CDs smcmlln Linux - Hardware 9 09-05-2005 07:48 PM
GRRR having a problem with mounting cds linuxmandrake Linux - Hardware 4 06-19-2005 11:46 AM
Problem mounting CDs Lossenelin Linux - Hardware 0 06-17-2005 06:34 AM
Problem mounting Audio CDs in KDE Kyle Linux - General 3 02-16-2004 09:18 PM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration