LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Poor sound quality in linux? (http://www.linuxquestions.org/questions/linux-general-1/poor-sound-quality-in-linux-235365/)

Jilted 09-26-2004 08:26 AM

Poor sound quality in linux?
 
Hi!

One of the big issues I have with Linux is the poor soundquality. My main thing that I do with my computer is to listen to music. And the soundqualtiy compared to Windows is very bad. I Have the nForce Soundstorm. Ok, now its been I while since I'v tested linux, have the drivers been improved much?

Best regards,
Michael

Ps. Im from sweden so have indulgence with my english :) Ds.

SciYro 09-26-2004 08:45 AM

well. seems your english is better then mine :)

anyways, maybe you would consider pointing out what was poor exactly? fuzzy ?, maybe it was choppy?, or burpy?

hw-tph 09-26-2004 08:52 AM

Welcome to LinuxQuestions. :)

What drivers do you use? I have a desktop with an Abit NF7-S revision 2 board (nforce2) and using the Alsa driver snd-intel8x0 I get as good or even better audio quality than in Windows. nvidia's own "platform drivers" that provide network and audio functionality aren't that great IMHO - try Alsa for sound and the forcedeth module for the onboard network.


Håkan

Jilted 09-26-2004 09:16 AM

Thanks for the replies :)

Ok. Maybe I should have described the problems :) Anyways, don't know the word in english, crunchy? :) And for example when I watched a movie and paused it and wanted to play a song it said that the driver was busy, like in Windows 95. Dont know wich drivers I used, it worked form the begging, I used Fedora Core 2.

Michael

demmylls 09-26-2004 10:41 AM

try to go to sound mixer program and turn off some feature
i have once had this problem also

SciYro 09-27-2004 05:05 AM

iv been told it was a sound card problem, well ... might be a different problem i was in (but theres many problems that can resemble the same effects)


anyways, for me it was because it was a cheap sound card


the sound card can only accept 1 program to play sound at a time (for the cheap cards, i think cards with that thing called full duplex can mix the audio from multiple programs at once and play them ...)

anyways, if it is sound card, use esd or arts (arts is usually for kde, gnome uses esd, but esd doesn't really on any gnome-only lib, i don't know about arts) .. ... these programs will act as a sound server so other apps can ask them to play sound,... kinda making those cheap cards that cant combine sounds into cards that can (as long as programs use the sound server, and not alsa/oss directly)

codec 09-27-2004 06:59 AM

try to turn off alsa 3d sounds. The 3d effect is not good for all audio files.


All times are GMT -5. The time now is 07:16 AM.