LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-08-2003, 08:35 AM   #1
DoobyWho
Member
 
Registered: Feb 2003
Posts: 50

Rep: Reputation: 15
PHP error? Or MySQL error?


I installed PHP/MySQL and i think i made the mistake of installing MySQL after PHP.

When i visit a page with just PHP on it, it works fine. But when the PHP deals with MySQL, it will like not parse that PHP portion.

If i did in fact install MySQL after PHP and apache, what do i need to change and where is it?
 
Old 04-08-2003, 09:06 AM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
MySQL can be installed by itself (regardless of order).

Apache is required by PHP, so Apache would have to be installed first.

The package called 'php-mysql' should be installed last, and I'm guessing this is what you are missing.
 
Old 04-08-2003, 09:48 AM   #3
DoobyWho
Member
 
Registered: Feb 2003
Posts: 50

Original Poster
Rep: Reputation: 15
When i try to install the php-mysql package it says it cant locate php = mysql4.2.2-8.0.7

But php is installed ...
 
Old 04-08-2003, 10:26 AM   #4
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Did you install php from a package? What about MySQL?
 
Old 04-08-2003, 10:27 AM   #5
DoobyWho
Member
 
Registered: Feb 2003
Posts: 50

Original Poster
Rep: Reputation: 15
Yes to both. I think i have 4.2.2-8.0.5 tho
 
Old 04-09-2003, 10:31 AM   #6
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
It sounds like you need to install the php-mysql-4.2.2-8.0.5 package.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
php-mysql error jkmartha Linux - Newbie 4 04-29-2005 04:40 AM
php, mysql error Alexander.s Programming 6 04-26-2005 04:51 PM
Error connecting to MySQL from PHP anindyanuri Linux - Software 18 04-24-2005 09:30 AM
PHP 4.3.1 Make Error with MYSQL SForsgren Linux - Software 2 05-23-2003 02:02 PM
PHP/MySql Error cmfarley19 Linux - Software 4 05-12-2003 12:26 PM


All times are GMT -5. The time now is 01:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration