LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Partition with boot flag doesn't boot anymore (http://www.linuxquestions.org/questions/linux-general-1/partition-with-boot-flag-doesnt-boot-anymore-4175424066/)

GilJ 08-26-2012 11:58 AM

Partition with boot flag doesn't boot anymore
 
Hi,

I have several linux distributions on my laptop (about eight). Each have their own set of partitions (on an extended partition) for boot, root, home and var (swap and tmp are shared).
I was using a boot partition to run grub2 to show the menu and allow the chainloading to each distro boot partition (with their own grub or lilo), and everything was working ok.

The thing is, after an automatic (big mistake) Ubuntu upgrade (11.10 to 12.04), the Ubuntu boot partition started to show up first. I thought I just needed activate the other partition boot flag, but using GParted or cfdisk, that partition is already marked with the boot flag?? How come a boot partition without the boot flag boots at system restart and the one with the flag doesn't?
Is there other configuration that can mark a partition as the one to boot first?

Thanks!

SecretCode 08-26-2012 01:12 PM

Not sure, but I think the boot flag is irrelevant and only used by Windows OSes.

What's probably happened here is that the Ubuntu install has rewritten the master grub, so that on boot, GRUB2 loads from the Ubuntu 12.04 partition and presents a menu with itself first and all the other OSes it finds as the rest of the list.

You'll need to reinstall GRUB2 from the boot partition with the configuration you want. THE MBR defines which partition is booted, not the boot flag, and the data in the grub.cfg file on the boot partition defines the menu of OSes you see.

Unfortunately I think the default installation of Ubuntu always writes GRUB to the MBR - they've taken away the ability to skip it.

GilJ 08-27-2012 04:00 AM

Thank you SecretCode :)


All times are GMT -5. The time now is 01:41 AM.