LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-26-2012, 11:58 AM   #1
GilJ
LQ Newbie
 
Registered: Jun 2012
Distribution: Gentoo, Fedora, Ubuntu
Posts: 4

Rep: Reputation: Disabled
Partition with boot flag doesn't boot anymore


Hi,

I have several linux distributions on my laptop (about eight). Each have their own set of partitions (on an extended partition) for boot, root, home and var (swap and tmp are shared).
I was using a boot partition to run grub2 to show the menu and allow the chainloading to each distro boot partition (with their own grub or lilo), and everything was working ok.

The thing is, after an automatic (big mistake) Ubuntu upgrade (11.10 to 12.04), the Ubuntu boot partition started to show up first. I thought I just needed activate the other partition boot flag, but using GParted or cfdisk, that partition is already marked with the boot flag?? How come a boot partition without the boot flag boots at system restart and the one with the flag doesn't?
Is there other configuration that can mark a partition as the one to boot first?

Thanks!
 
Old 08-26-2012, 01:12 PM   #2
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Not sure, but I think the boot flag is irrelevant and only used by Windows OSes.

What's probably happened here is that the Ubuntu install has rewritten the master grub, so that on boot, GRUB2 loads from the Ubuntu 12.04 partition and presents a menu with itself first and all the other OSes it finds as the rest of the list.

You'll need to reinstall GRUB2 from the boot partition with the configuration you want. THE MBR defines which partition is booted, not the boot flag, and the data in the grub.cfg file on the boot partition defines the menu of OSes you see.

Unfortunately I think the default installation of Ubuntu always writes GRUB to the MBR - they've taken away the ability to skip it.
 
2 members found this post helpful.
Old 08-27-2012, 04:00 AM   #3
GilJ
LQ Newbie
 
Registered: Jun 2012
Distribution: Gentoo, Fedora, Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you SecretCode
 
  


Reply

Tags
boot, grub


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
formatting an ntfs partition with a boot flag saadia1912 Linux - General 3 11-10-2008 09:53 PM
Booting XP resets boot flag to its partition gavinbeatty Linux - General 6 12-26-2006 08:04 PM
Slackware 10.2 doesn't boot anymore bmxer_br Slackware 5 06-21-2006 02:48 AM
doesn't boot anymore sjefke37 Linux - Software 12 08-01-2004 08:40 AM
laptop doesn't boot anymore sear Linux - Hardware 1 07-15-2004 02:11 PM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration