LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Packages.gz without lib dependencies: error when apt-get update (http://www.linuxquestions.org/questions/linux-general-1/packages-gz-without-lib-dependencies-error-when-apt-get-update-527912/)

Xeratul 02-12-2007 03:59 PM

Packages.gz without lib dependencies: error when apt-get update
 
Hello,


I made a deb-package-file *.deb with checkinstall, hence,
in my Packages file, there is nothing next to Depends:
Sooo, apt-get update gives me an error since he cannot see any depends, as shown below.
How to make it work without making again my debs ?
What would have been the easiest way to make my debs once : sh ./configure ; make ; make install ?

thank you very much !!



Packages file:
Code:

...
Architecture: i386
Version: 0.12.3
Depends:
Filename: kopete blabla...
...

Code:

/etc/apt# apt-get update
Ign file: etch Release.gpg
Ign file: etchperso Release.gpg
Ign file: etch Release
Ign file: etchperso Release
Ign file: etch/contrib Packages
Ign file: etchperso/contrib Packages
Reading package lists... Error!
E: Problem parsing dependency Depends
E: Error occurred while processing kopete (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/blabla ....

E: The package lists or status file could not be parsed or opened.



All times are GMT -5. The time now is 01:17 AM.