LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-28-2003, 03:40 PM   #1
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Rep: Reputation: 30
Package dependecy errors when installing KDE 3.1.1 in RH8


Running RH8 I d/led KDE 3.1.1, all packages. site said I needed qt3.1.2 which there were rpms for in the KDE3.1.1 dir on the ftp site so I d/led those followed instuctions installing arts rpm using the rpm manager in gnome, worked fine, went to install the qt rpms but it gave me dependency error saying that I needed QT 3.1.2 to be installed??? What the..??? it is QT 3.1.2??? so I D/Led the tar.bz2 file from the QT site <something>troll.com or troll<something>.com followed the instructions exactly. rebooted comp just to be sure. went to install kdelibs rpm said I needed qt >= 3.1.2 and kdelibs = 3.0.3... What the shmeg is going on here??? I'm totally lost.
 
Old 03-28-2003, 05:16 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
When installing from RPMs (KDE from RPMs) you need QT from RPM, too. The right order is:
qt
arts
kdelibs
kdebase
You can get source QT RPM from ftp://ftp.kde.org/pub/kde/stable/3.1....8x.1.src.rpm, remember that it's source, so you need to rebuild it. It's not enough to install. You can read more about *.src.rpm files here: http://www.linuxquestions.org/questi...ce+rpm+install
 
Old 03-28-2003, 05:24 PM   #3
acid2000
Member
 
Registered: Nov 2001
Location: Exeter, UK
Distribution: Gentoo 1.4
Posts: 243

Rep: Reputation: 30
This is a classic case of why I hate rpms.
 
Old 03-28-2003, 05:38 PM   #4
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Original Poster
Rep: Reputation: 30
Krykie, that was wierd. I just barely learned about SRPMS and how to install them at about the same time you were posting your message Mara.(NVIDIA kernel Driver is an SRPM) Anyhow, thanks gonna try that now. I'll let you know how it goes.
 
Old 03-28-2003, 06:12 PM   #5
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Original Poster
Rep: Reputation: 30
Okey Dokey. I type 'rpmbuild --rebuild qt-3.1.2-0.8x.1.src.rpm' into the root console. AND I GET MORE FAILED DEPENDECY ERRORS!!!! Now it's saying that I need mysql-devel, postgresql-devel, and unixODBC-devel for qt-3.1.2-0.8x.1 Where do I get those?!?
 
Old 03-29-2003, 03:19 AM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
Quote:
Originally posted by kierl
Now it's saying that I need mysql-devel, postgresql-devel, and unixODBC-devel for qt-3.1.2-0.8x.1 Where do I get those?!?
From one of your installtion cds or from Redhat FTP sites, I guess. I think they're on 2nd cd.
 
Old 04-01-2003, 09:52 AM   #7
txtoolman
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2 and above
Posts: 18

Rep: Reputation: 0
I just downloaded KDE myself from KDE.ORG. The files you are looking for are there.

I too had quite an evening last night trying to upgrade my KDE to 3.1.1 ( hint: there are no readmes or install files with the rpms ). I finally figured some of the order like Mara stated. However, when I went to install the kdebase, it said there were conflicts with apps LISA, and KDEUTILS-LAPTOP. Not sure if I should just remove the original kdebase package, or not. Anyone is welcome to help out.

This really should be a little easier to do (at least throw in a readme or install file). I'm a little suprised RedHat does not have these available on their site yet.
 
Old 04-01-2003, 11:55 AM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
Remove the apps, but make sure you have the RPMs to install them again in case of problems with KDE 3.1.1.
 
Old 04-01-2003, 01:36 PM   #9
txtoolman
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2 and above
Posts: 18

Rep: Reputation: 0
Just for clarification: do you mean to remove the KDEBASE package, or the LISA & KDEUTILS-LAPTOP package(s)?
 
Old 04-01-2003, 04:24 PM   #10
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Original Poster
Rep: Reputation: 30
Found packages (on 3rd CD) but when I try to install the mysql-devel package it tells me I need mysql ver 3.23.52-3 but it is already installed...?!
 
Old 04-03-2003, 12:45 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
Make sure it is:
rpm -qa mysql
If you can find it on the list use RPM with --nodeps option.
 
Old 04-04-2003, 08:12 AM   #12
txtoolman
LQ Newbie
 
Registered: Mar 2003
Distribution: RH 7.2 and above
Posts: 18

Rep: Reputation: 0
I forgot to post my results: after removing the 2 conflicting packages (checked on the RH site to see what the packages are for), I was able to install all the needed files, and now have KDE 3.1.1 on my system. KDE does run slow on older systems, but the selections and choices you can configure in there are numerous.

to kierl: any -devel package you install, you will also need the regular package to go with it. I personally don't have them since I am not doing any development on my system.
 
Old 04-04-2003, 02:12 PM   #13
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Original Poster
Rep: Reputation: 30
Okay... prob found, I think... for some strange reason, probably thanks to RHN Up2Date, I'm running mysql ver 3.23.54a-4... gonna try finding the dev package for that ver...
 
Old 04-04-2003, 02:44 PM   #14
kierl
Member
 
Registered: Oct 2002
Location: Utah
Distribution: Gentoo(2.6.23-r3)
Posts: 181

Original Poster
Rep: Reputation: 30
Okey Dokey... Cannot find mysql-devel packages...? Any Ideas?
 
Old 04-04-2003, 03:16 PM   #15
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
If you *REALLY* can't find it (it's strange, the packaga should be somewhere), try to install the old one, from console, with --nodeps switch:
rpm -i package --nodeps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmame-bin found as dependecy when installing roms PolishSausageof Linux - Software 0 11-26-2004 12:02 AM
PPP package errors ( installing USB DSL Modem) meat_n2_reg Linux - Software 7 11-05-2003 01:58 PM
Installing KDE via RPM > Dependecy hell jon_k Linux - Software 10 08-27-2003 02:48 PM
RH8.0 - package management: howto remove KDE tetractis Linux - Distributions 2 01-29-2003 04:33 AM
Which package gives the file -lXpm? <<Errors while installing Pcmcia-cs-3.1.25>> RKris Linux - Software 3 06-14-2002 05:13 AM


All times are GMT -5. The time now is 09:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration