LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-10-2004, 08:05 PM   #1
NLawrence
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Rep: Reputation: 0
OpenGL Games freeze after 10-15 minutes of play


Current System:
600Mhz PIII (100Mhz fsb)
128MB PC-100 RAM
nVidia TNT2 Ultra (32MB)
40GB WD EIDE Hard Drive
Red Hat 8 - 2.4.18-14


I've been running RH8 for about two months now, and I love everything about it.... I've learned so much about computing and OS's that I didn't know, after thinking I had it all down in MS. I feel like there's infinite potential for learning with Linux, and it's just.. beautiful.

Anyhow -- I've been trying to get games to work on here (Specifically Neverwinter Nights' Linux Client) and I'm using the Quake III Arena Demo as well. So far, BOTH of these games are exhibiting the same problem -- I'll get anywhere from five to twenty minutes of play, and then (In KDE & Gnome) the system will completely lock up, and I'll be unable to do anything except a hard reboot. In straight X, 90% of the time it will exit with a signal 11 and I can just start up again. I've tried *everything* that I can find to do, including change the

Option "NvAGP" "3"

line to "1" and "0," as well as recompiling the nVidia drivers (The ones from their website, the newest NVIDIA-Linux-x86-1.0-5336-pkg1) to set the AGP size down to 1. Still no luck there, however, it does give me extended time (the twenty minutes) to play. The next thing that I tried was a rather poor mod to my TNT2 card, where I got some paperclips and put an old CPU fan from my P5A-b board onto it, as well as adding another fan to draw more air towards the card. I'm at my wit's end here, as nothing I seem to do will fix this problem.

My current XF86Config file:



# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell Vi14X"
DisplaySize 267 203
HorizSync 35.5 - 35.5
VertRefresh 87.0 - 87.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "NvAGP" "3"
VendorName "Videocard vendor"
BoardName "RIVA TNT2"
VideoRam 32768
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Now, the other thing that I've noticed (And it's not /AS/ big of a deal to me -- Getting the games to work is my main concern) is that after I'm kicked out of the game with the signal 11, or even if I quit prematurely, all of my text will be off -- legible, sort of, but it's all weird. I can't explain it properly.

Anyhow. Thanks, to all of y'all in advance, for whatever you can do to help. If this is a hardware/software issue, just let me know, and I'll switch to those forums.

Again, thanks.

-Nathan
 
Old 04-11-2004, 12:32 AM   #2
NLawrence
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Erm... Anyone? Anyone at all? I'm at the point where I'm willing to try anything, crazy as it may be...
 
Old 04-11-2004, 12:51 AM   #3
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Well, look in /var/log
and read ALL of the message files to see what/where the errors are/may be happening.
 
Old 04-11-2004, 12:55 AM   #4
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Hey NLawrence!. Quite odd problem you got there . Well, the only thing that I can recommend ya is to get an older Nvidia driver. Their newest release tends to be buggy, for while. They have an unified driver to all their cards, so it's common to find a problem in this or that card from time to time. Another thing that you could try to do is to uncomment your line where it stands glx:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

I know you've to comment out something(I am almost sure that it was glx line). This machine that I'm running now is Solaris, so I cannot test for sure, but I think it was glx that I commented out. To comment out, simply put a hash (#) at the beginning of the line, like this:

# Load "glx"

So, since you are willing to try everything, try first commenting out that line (make backup first). If you still get the same crashes, try an older driver. If you still keep getting crashes, maybe something went bad with your graphics card .

Good luck!

Last edited by Mega Man X; 04-11-2004 at 12:56 AM.
 
Old 04-11-2004, 01:53 AM   #5
NLawrence
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks to both of you -- I check the readme for the nVidia drivers, and it said:


If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

So... dunno on that. Going through the error logs (i'd already been through the X logs, nothing) I couldn't seem to find anything... But, NwN does have error logging. So... I'm going to try and go crash it now and then grab the errors from it. And then I'll try an older driver. Thanks, both of y'all.
 
Old 04-11-2004, 04:06 AM   #6
NLawrence
LQ Newbie
 
Registered: Feb 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Solution! :D

Okay. So.... I couldn't get NwN to give me any error output, and had to restart.

Anyhow! I went and started trying the older versions of the drivers from

http://www.nvidia.com/object/linux_display_archive.html

The first IA32 broke X horribly... So... since I was still in init 3, I fired up Lynx and went and got

http://www.nvidia.com/object/linux_d..._1.0-4496.html

Install went smooth, I fired up X all by itself, and then ran the Q3 demo -- Played all the way through the first two difficulty settings, no problems.

Thanks to both of y'all... Planning on upgrading to FC here soon, so I'm sure everything will just break again.
 
Old 04-11-2004, 09:38 AM   #7
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Cool NLawrence!!!

So it was really the drivers huh . Sorry to have made a wrong suggestion for you to comment out the line load "glx", but hey, very clever of you to check the official documentation . And interesting that every new driver from Nvidia has some problem... They should use a slogan more or less like: "The latest is never the greatest..."
 
Old 04-17-2004, 06:44 PM   #8
psychofari
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Hey !

Great to find someone with the same problem.. apparently solved !!

I heard some bad news about these 5336 drivers before (especially with 2.6.x kernel series) but not payed much attention, and now every GL related application I launch (UT2004 Demo, OpenGL screensavers... even glxgears !) freezes after a random amount of time (thanx the kernel Magic Keys : http://www.linuxmafia.com/faq/VALinu...s-support.html).

So I'll try these 4496 I've been advised before, hope it'll work !

NLawrence, I just want to says that it's no deficient hardware, mine :
Athlon 2800+
GF FX 5200
1 Gb RAM DDR
Debian unstable 'Sid' under 2.6.5 kernel

Thanx in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dialup connection freeze after a few minutes cyberjun Linux - Networking 4 03-14-2005 02:24 AM
opengl freeze waslit Linux - Hardware 3 06-25-2004 12:14 PM
OpenGL Games cause hard system crash after 1-5 minutes Ehuwiko Linux - Games 5 06-23-2004 05:53 PM
Anyone been able to play opengl games in wine using ATI Radeons? TheOneAndOnlySM Linux - Hardware 0 02-14-2004 12:26 PM
why does my 9.2 freeze every 20ish minutes? rosscopeeko Mandriva 14 02-12-2004 02:39 AM


All times are GMT -5. The time now is 05:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration