LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-18-2009, 03:03 PM   #1
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 147Reputation: 147
OpenGL apps won't run in window mode properly (Compiz enabled)


Hi, all. I'm having a problem with OpenGL appliacations that can run in either windowed or fullscreen mode (e.g. games, Blender, etc.). When I try to either start the application in windowed mode, or if I choose windowed mode from an in-app menu, it will simply flicker. I have compositing enabled; presumably this is Compiz redirecting video output to an off-screen texture before displaying it on-screen (as it should do with non-fullscreen windows). When I switch to different resolutions while the application is in "windowed" mode, it will simply resize the display area of the application (according to the origin at the top-left corner of the screen) while leaving black in the unused space.

I've googled "opengl applications always fullscreen" and "opengl won't switch to windowed mode" and neither came up with any useful results. I also searched LQ with the same terms and found nothing useful.

It hasn't always been this way...I don't know exactly when it started happening, but I don't recall manually changing any of the configuration files for the applications, or xorg.conf.

I'm guessing there probably is something I need to do with configs, though. I just need a nudge in the right direction.

The applications I'm noticing this most with are Blender and Neverball. It also applies to any other OpenGL game I try to run. The only thing I can think of that isn't affected by this is DOSBox, and I'm pretty sure I have that running with OpenGL set as the output mode.

EDIT: The DOSBox thing is probably because it destroys the original window, creates a new maximized one and vice versa when switching between modes.

Last edited by MrCode; 11-19-2009 at 04:00 PM.
 
Old 11-18-2009, 04:23 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
You could try adding a keystroke combination which would allow you to switch between full and windowed modes.
 
Old 11-18-2009, 04:42 PM   #3
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Original Poster
Rep: Reputation: 147Reputation: 147
Quote:
Originally Posted by Mr-Bisquit View Post
You could try adding a keystroke combination which would allow you to switch between full and windowed modes.
That's not exactly the problem.. The thing is, when I try to switch to windowed mode, it will basically stay in fullscreen mode, but the display will resize when I change resolution (i.e. without the monitor actually changing resolution).

Sorry if I didn't make that clear in my first post. I know I was a little on the talky side
 
Old 11-19-2009, 01:50 AM   #4
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
How are you switching between the two modes?
 
Old 11-19-2009, 07:18 AM   #5
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Original Poster
Rep: Reputation: 147Reputation: 147
In Blender I'm using the "(windowed)" option in the Applications menu (blender -w supposedly gives the same result, but it doesn't work for me, either), and in games, I'm simply using the in-game menu options for switching resolution and fullscreen/windowed modes.
 
Old 11-19-2009, 02:58 PM   #6
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
The game engine and rendering engine are two different parts of blender.
Keep it windowed.
Have you asked at the blender forums for help with this?
 
Old 11-19-2009, 03:45 PM   #7
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Original Poster
Rep: Reputation: 147Reputation: 147
Err...I'm not talking about Blender's game engine when I say "games". I'm talking about completely separate programs.

I've attached some screenshots to clarify what's going on.

The first one shows Neverball in what is supposed to be windowed mode, but as you can tell, it isn't. The second one shows the resizing of the display area (without the monitor switching resolution) when I change the resolution in the game preferences.

With Blender, essentially the program is starting in fullscreen mode, even though I specified windowed mode.

Please excuse the garbled-ness of the first screenie, I think it's the screenshot utility that does that sometimes when running under a compositing window manager. You can see that the fullscreen setting is set to off, though. If it were working properly, you would be able to see the GNOME panels and window decorations, even though the resolution is still set to 1440x900 (my monitor's native resolution).

Perhaps this is a problem specific to Neverball and Blender individually, though...if it is, I apologize for having wasted time here.

EDIT: Changed thread title to state that I have Compiz enabled...that could be part of the problem (or THE problem, who knows...)

Last edited by MrCode; 03-13-2011 at 01:29 AM.
 
Old 11-19-2009, 04:00 PM   #8
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Original Poster
Rep: Reputation: 147Reputation: 147
Solved. Turns out Compiz was the problem...kinda sucks that I have to disable it if I want to use Blender in windowed mode, though
 
Old 11-21-2009, 03:14 AM   #9
rohitmehta
LQ Newbie
 
Registered: Nov 2009
Posts: 9

Rep: Reputation: 1
http://funlinuxfun.blogspot.com

http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com http://funlinuxfun.blogspot.com

How to enable and use Desktop Effects (Compiz) in openSUSE11.0

openSUSE 11.0 comes preinstalled with Compiz and Compiz-Fusion 0.7.4 pre-installed.

Enable Compiz/ Desktop Effects
To enable Compiz, referred as Desktop Effects in openSUSE 11.0
From Applications – Configure Desktop – Desktop, tick the box for “Enable Desktop Effects” and click Apply. This should enable Desktop Effects / Compiz on your openSUSE.

Alterntaivelty, you can enable from
Application – Utilities – Desktop – Desktop Effects – select the checkbox for “Enable Desktop Effects” and close.

Here you can also, select a preset profile for your Desktop Effects ranging from minimal to Ultimate.
Once enabled, we are all set to start using desktop effects or Compiz on openSUSE 11.0.


Now, that we have installed and enabled Desktop Effects (Compiz) in our openSUSE, how do we use it?

Compiz Fusion / Desktop Effects enables a bunch of plugins by default and one of them is the Desktop Cube. The Destop Cube shows the multiple workspace on your desktop as a Desktop Cube. Imagine your Desktop as your cube and each side of the cube is a workspace in your multiple worlspace desktop and thats exactly is a desktop cube. This cube can also be unfolded and shown as a strip of slides where each slide is a desktop workspace.

Prior to enabling and using Desktop Cube, the most important aspect of the Desktop Cube are your keyboard and mouse (or touchpad in case of a laptop)
Apart from the standard special keys on your keyboard like keys there are few others, you need to familiarise with. They are
Super Key – “Windows Key” on your keyboard (if found)
Mouse Key mappings
Button1 – Left-click button on your mouse
Button2 – Right-Click button on your mouse
Button3 – Middle click button or clickable wheel on your mouse
Button4 – Forward scroll on the wheel of your mouse
Button5 – Backward scroll on the wheel of your mouse
Enable Desktop Cube
Let’s first see how to enable the Desktop Cube and the Rotation. The Desktop Effects or Compiz Fusion plugins can be enabled from CompizConfig Settings Manager (ccsm). This can be started from Applications – Applications – CompizConfig Settings Manager or can be started from the terminal as follows:
opensuse11:~ # ccsm
This should launch the CompizConfig Settings Manager

Here, select the checkboxes for “Desktop Cube” and “Rotate Cube”. This enables the Compiz Desktop Cube.
Start Desktop Cube
Lets have a preview, to start the Desktop Cube,
1. Press and hold the keys + on the keyboard.
2. While holding the keys, click, hold and drag the Button1 (left click button on mouse). Drag in any direction to view the cube
You should see the cube in action, each side of the cube is a desktop workspace. How is that for a start????
Almost everything about the cube is customizable, from the image on top of the cube or the background image of the cube (Skydome as in Compiz). To customize the Desktop cube, from the CCSM, click the Desktop cube to open the properties.
In the properties window,
the General tab allows you to change the key mapping

the Appearence tab allows to customize the appearence, change images for cube top and background (SkyDome)

the Behaviour tab allows to change the cube behaviour. For instance, to view the cube from the inside

the Transparent Cube tab allows to change the transparency setting.

Lets have a look at some of the effects of the Desktop Cube
Unfold the Cube
To unfold the cube and show it as a strip of slides with each slide representing one side of a Cube
1. Press and hold +. This should bring up the strip.
2. To move the strip, while holding the above the keys, press the or the to move in that direction. You may press and hold this key (say for a running strip
Inside Cube
By default, the cube is viewed from the outside of the cube. lLets for a change look the desktop cube from the inside.
1. Bring up the properties for Desktop Cube and click Behaviour tab.
2. Select the “Inside Cube” check box.
Now bring up the cube as earlier and see the difference
Desktop Cube in Sphere or Cyclinder
Again, the Desktop Cube is by default viewed in square edges where each side is a desktop workspace. Why not view it as a cyclinder or a Sphere. Possible??? Why not?
1. Enable the “Cube Reflection and Deformation” plugin under Effects in CCSM.
2. Click on it to bring the properties and click the “Deformation” tab
3. Select Cyclinder or Spehere from the Deformation listbox.
Now, bring up the cube and see the different… mind blowing!!!
This effect will also be seen when you unfold the Desktop Cube
3D Windows
All is great so far…Why not a 3D effect onto the cube??
Enable the “3D Windows” plugin under effects.
Bring up the Desktop Cube, you should see the active windows in your cube are shown seperately as a 3D window.
Reflection
Enable the Reflection plugin under effects in CCSM and you should see the reflections on the window when the cube is evoled again. This is the reflection of the image selected. To change the image, click on “Reflection” plugin and choose the image of your choice.
NOTE: On unsupported display/video cards (say Intel 965GM), thus can crash your display.
Hope you had a great preview of your compiz/Desktop Effects. I couldn’t workout a way to capture these while in action than to use my cameras and hence no screenshots of Desktop Cube in action.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Run X-window Apps without GUI? sanitynotvanity Linux - Desktop 3 12-07-2007 08:52 AM
I can't get avant-window-navigator to run properly jobbe Linux - Software 2 09-15-2007 01:43 PM
Can GLX / Compiz cause, my OpenGL game apps work only in windowed mode? gerytay Linux - Games 2 10-30-2006 04:46 AM
Run application window in su mode liaty Linux - Software 8 07-25-2006 08:49 AM
SuSE 10, KDE 3.4: OpenGL apps only work when run as root pschoenb Linux - Software 1 11-10-2005 01:43 PM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration