LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Online Dictionary and dict.org (http://www.linuxquestions.org/questions/linux-general-1/online-dictionary-and-dict-org-644326/)

gymnart 05-23-2008 01:29 PM

Online Dictionary and dict.org
 
I've been happily using the online dictionary from my SuSE 10.0 system (Office > Database > Online Dictionary) But today when I tried to use it, all it does is timeout. It has never done this before. I have not changed any settings with it either.

When I went to dict.org, the page and database were there and that worked just fine.

So, I wonder what they changed, if anything at all? I can't even get server info from the app. anymore. The port # that is used is: 2628.

{BBI}Nexus{BBI} 05-23-2008 10:54 PM

I don't think this is a distro problem. I am using Mandriva and I have had this problem for quite a while now. I have not to date been able to find a reason (nor a solution) for this bizzare fault.

gymnart 05-24-2008 01:16 PM

Thanks so much, Nexus, I thought I had busted it or something.
Maybe they closed, or changed the port or something?

berbae 05-24-2008 05:55 PM

It's not the port 2628, because it works on my machine using kdict.
Are you sure the port is not closed by a firewall ?

{BBI}Nexus{BBI} 05-25-2008 07:45 AM

Quote:

Originally Posted by berbae (Post 3163643)
It's not the port 2628, because it works on my machine using kdict.
Are you sure the port is not closed by a firewall ?

I don't know if gymnart has checked, but I can confirm my firewall is not blocking that port. There are no other apps using that port either.

{BBI}Nexus{BBI} 05-25-2008 09:08 PM

@gymnart: Try testing if your blocking access to port 2628 by installing telnet-client then do as a normal user: telnet dict.org 2628. If you don't connect then something is blocking that port.

{BBI}Nexus{BBI} 07-12-2008 10:33 AM

Quote:

Originally Posted by {BBI}Nexus{BBI} (Post 3164027)
...I can confirm my firewall is not blocking that port...

I stand corrected. It seems I didn't quite check my firewall thoroughly enough. On looking again I omitted the outgoing connection settings. I have now rectified this and all is well. :)

gymnart 07-12-2008 03:25 PM

Nexus,
How did you check your firewall for the port blockage? I can ask my husband to check it.

{BBI}Nexus{BBI} 07-12-2008 03:30 PM

Quote:

Originally Posted by gymnart (Post 3212482)
Nexus,
How did you check your firewall for the port blockage? I can ask my husband to check it.

I have a standalone firewall on a separate machine, it's called Smoothwall. Have him check the outgoing connections on your firewall. Which is it that you are using?

gymnart 07-12-2008 04:51 PM

It's fixed now. Yes, it was the router settings.


All times are GMT -5. The time now is 08:37 AM.