LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   odd behaviour of wvdial (http://www.linuxquestions.org/questions/linux-general-1/odd-behaviour-of-wvdial-349708/)

NNP 08-03-2005 05:45 PM

odd behaviour of wvdial
 
Ok, this is regarding my internet connection using wvdial. Im using Fedora core 4 by the way. If i use kppp i can connect to the net fine and everything works away ok but I prefer to use wvdial. For some reason though if i type wvdial at the command line i get

Code:

[nnp@main ~]$ wvdial
--> WvDial: Internet dialer version 1.54.0
--> Cannot open /dev/ttyS0: Device or resource busy
--> Cannot open /dev/ttyS0: Device or resource busy
--> Cannot open /dev/ttyS0: Device or resource busy
[nnp@main ~]$

I thought it might be a permissions problem so to test i switched to root and everything worked fine. The problem then though was i couldnt connect to any sites. I was getting "host not found" messages from firefox and pinging hostnames got me "unknown host" messages,

I set the permissions the same as root so i dont think its that.
Code:

[root@main nnp]# cd /usr/bin
[root@main bin]# chmod 775 wvdial
[root@main bin]# ls -al wvdial
-rwxrwxr-x  1 root root 125736 Mar  3 13:11 wvdial
[root@main bin]# exit
exit

Here is my config file if that helps

Code:

[Dialer Defaults]
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = 1890924042
Username = free
Password = free

I know its not a firewall issue as a)I disabled it and b)I can work fine with kppp(if a little slowly)

Any ideas?

NNP

cdhgee 08-03-2005 07:03 PM

I had this exact same problem and like you I'd verified all the permissions were set correctly. The only way I found to resolve the problem was to make wvdial setuid root:

Code:

chmod o+s `which wvdial`
That way wvdial will always run with root privileges. Needless to say, this is not ideal and is a potential security risk but after posting to this forum (see http://www.linuxquestions.org/questi...hreadid=348563) about the problem the general consensus was to make wvdial setuid root to solve the problem.

NNP 08-04-2005 06:30 AM

Wierd, is this a Fedora Core problem? I never had this while using Mandriva.

NNP 08-05-2005 03:11 PM

Ok i've done that and its still the same crap. ANy ideas? Here is the output

Code:

[nnp@main ~]$ su
Password:
[root@main nnp]# chmod o+s `which wvdial`
[root@main nnp]# exit
exit
[nnp@main ~]$ wvdial
--> WvDial: Internet dialer version 1.54.0
--> Cannot open /dev/ttyS0: Device or resource busy
--> Cannot open /dev/ttyS0: Device or resource busy
--> Cannot open /dev/ttyS0: Device or resource busy
[nnp@main ~]$ ls -al /usr/bin/wvdial
-rwxrwxr-x  1 root root 139872 Mar  3 13:11 /usr/bin/wvdial
[nnp@main ~]$


cdhgee 08-05-2005 03:58 PM

Odd. Looks like the chmod command didn't work. Try it like this instead:

Code:

chmod o+s /usr/bin/wvdial


All times are GMT -5. The time now is 11:59 PM.