LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-29-2006, 02:36 PM   #1
Last Attacker
Member
 
Registered: Jun 2004
Location: South Africa
Distribution: Ubuntu
Posts: 120

Rep: Reputation: 15
NTFS Mount


Hi,
As some may know, I have SuSE 10.0 installed on my machine. I think I might have done something which I shouldn't have (during the SuSE installation) and now only Root can mount the NTFS partition on my drive and access it while other users can't. Usually everyone had read access to the NTFS partition, since I sometimes want to copy stuff from Windows to Linux and I use YAReG with ReiserTools in Windows to copy stuff from Linux.

Could someone please tell me what I should type in the /etc/fstab file to let my sda1 device (the NTFS partition) be able to be mounted by any user in Linux but just for reading (including Root).
I tried, doing it myself but it only ends up being not mounted at all.
I have both Windows and Linux on a SATA drive on different partitions, obviously.
Any help appreciated!

Thanks
 
Old 06-29-2006, 02:54 PM   #2
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
This works for me:

Code:
/dev/sdb1 /mnt/win_n ntfs     ro,user,auto 0 0
So in your case replace sdb1 by sda1 and decide whether you want to risk rw.
 
Old 06-29-2006, 03:02 PM   #3
kevkim55
Member
 
Registered: Dec 2005
Location: Edmonton
Distribution: BLFS, Gentoo
Posts: 353

Rep: Reputation: 32
Put this in your /etc/fstab
Quote:
/dev/sda1 /windows/C ntfs users,gid=users,ro,umask=0222,utf8=true 0 0
Substitute /windowc/C by the mount point you prefer.
The above will give read only access to all users and should be mountable by any user.
 
Old 06-29-2006, 03:57 PM   #4
Lenux78
Member
 
Registered: Jun 2006
Location: Venezuela
Distribution: A Lot
Posts: 40

Rep: Reputation: 15
Try this way:
Example in /etc/fstab:

/dev/hda1 /windows/C ntfs ro,users,umask=022 0 0
/dev/hda5 /windows/D ntfs ro,users,umask=022 0 0
 
Old 06-30-2006, 03:19 AM   #5
Last Attacker
Member
 
Registered: Jun 2004
Location: South Africa
Distribution: Ubuntu
Posts: 120

Original Poster
Rep: Reputation: 15
Thanks guys! I'm gonna try them out now.
 
Old 06-30-2006, 03:34 AM   #6
Last Attacker
Member
 
Registered: Jun 2004
Location: South Africa
Distribution: Ubuntu
Posts: 120

Original Poster
Rep: Reputation: 15
Alright, cool! It works!
I used kevkim55's config settings. It works ok for me! Thanks a lot you guys.
 
  


Reply

Tags
mount, ntfs, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
Mount ntfs tataros3 Solaris / OpenSolaris 4 09-26-2005 02:01 PM
can't access ntfs mount through nfs mount bezoomny Linux - Networking 9 04-14-2004 10:25 AM
Mount NTFS in RW? glock19 Linux - Software 7 08-23-2003 07:40 PM
Mount NTFS - sorry gavinayling Linux - Newbie 1 07-03-2003 04:59 PM


All times are GMT -5. The time now is 01:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration