LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 05-09-2002, 04:05 PM   #1
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Rep: Reputation: 31
--nolisten tcp


Where do I put "--nolisten tcp" to make it so that X does not open a port?
 
Old 05-09-2002, 04:35 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,344

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
startx -- -nolisten tcp
 
Old 05-09-2002, 04:44 PM   #3
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
How do I make it so that anytime a user types "startx" on the system, it sends the "--nolisten tcp" argument.
 
Old 05-09-2002, 04:51 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,344

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
alias startx='startx -blah' in /etc/bashrc or similar
 
Old 05-09-2002, 05:01 PM   #5
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
I don't have a bashrc on the system. It's SuSE 7.0 by the way.
 
Old 05-09-2002, 05:53 PM   #6
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,170

Rep: Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585
glock19, what shell do you use?
 
Old 05-09-2002, 06:08 PM   #7
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
Oh, it's .bashrc

I have that.

But I want startx to pass the --nolisten tcp argument for ALL users on the system.
 
Old 05-09-2002, 06:25 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,344

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
is it really too much hard work to pay the slightest bit of attention? i said /etc/bashrc no ~/.bashrc if that's what i meant, that's what i would have said. you myst already have that file, if for some reason it's not there, use /etc/profile or /etc/rc.local or whatever.
 
Old 05-09-2002, 06:34 PM   #9
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,170

Rep: Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585Reputation: 2585
If your users you bash add it to /etc/profile. You can use /etc/csh.login if they use csh or tcsh.

--jeremy
 
Old 01-23-2003, 04:27 AM   #10
Xgates
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
Ok Lets do things the REAL Linux way :-)

glock19 the real way to do this is to go to /usr/X11R6/bin/startx or if your using some funky distro then do 'whereis startx' and locate the directory
open 'startx' and on this line:

serverargs="" change to this: ---> serverargs="-nolisten tcp"

Restart X bingo Bye Bye 6000
 
Old 01-27-2003, 11:31 AM   #11
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Original Poster
Rep: Reputation: 31
I tried that, and it didn't work.
 
Old 02-05-2013, 03:45 PM   #12
clcbluemont
Member
 
Registered: Feb 2009
Distribution: Slackware
Posts: 87

Rep: Reputation: 15
Dirty method is to find defaultserverargs="" in /usr/bin/startx and change it to defaultserverargs="-nolisten tcp"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
-nolisten tcp for X ferreter Fedora 3 07-19-2004 02:38 PM
SuSE 9.1 eliminating -nolisten tcp jdeisenberg Linux - Software 1 06-04-2004 04:38 PM
X server - how to disable the -nolisten tcp startx default? lugoteehalt Debian 3 05-04-2004 07:12 AM
startx -nolisten tcp shanenin Slackware 2 11-12-2003 04:00 PM
-nolisten tcp Xgates Linux - Security 4 01-23-2003 04:48 AM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration