LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-14-2004, 07:37 AM   #1
steve1401
Member
 
Registered: May 2003
Location: UK
Distribution: Debian
Posts: 73

Rep: Reputation: 15
no sound from audio CD, but all other sound works


Hi
Debian, kernel 2.6.9, ALSA installed and working with .ogg, .mp3, .wav etc using Intel AC'97 Audio Controller (rev 03), vaio laptop...

The audio works except when I try to platy a cd. I have just found that Totem player DOES work, but I would prefer to use xmms or xine. They both seem be playing (in xine the screen shows the funny audio wave graphic), the CD is spinning and all ALPS audio selectors are up and unmuted.

Any ideas.

Also, sorry if this post is similar to others, but none of the others (which I have found) provide a solution
 
Old 12-14-2004, 08:03 AM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
If I remeber correctly, you may need to turn off the system speaker or something similar in alsamixer. Could you list the available channels?
good luck.
 
Old 12-14-2004, 08:26 AM   #3
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
Just a thought, but when I had this problem, it was because I'd forgotten to connect the CD-ROM to the soundcard. Check your wiring

I don't know Totem, but there ARE applications around that reads the CD & turn the data into sound, rather than piping it straight from the CD-ROM to the card, and it could be one of them.
 
Old 12-14-2004, 09:45 AM   #4
Richey
Member
 
Registered: Oct 2003
Location: Dundee, Scotland
Distribution: SuSE Linux 9.2 (+8.1)
Posts: 44

Rep: Reputation: 15
What he said.

I had the same problem on my desktop box, but I don't know how confident you feel about opening up your laptop to check the wiring.

IIRC totem is a xine frontend? Maybe there are some options specific to totem that need to be enabled/disabled in the others?
 
Old 12-14-2004, 05:36 PM   #5
steve1401
Member
 
Registered: May 2003
Location: UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 15
Thanks for the responses.

Re the wiring, this shouldn' t be at fault, like I say, Totem plays CD's fine, just not xmms and xine (my prefered applications).

Re ALSA volume options;
Master - unmuted, turned up
Master Mono
Headphone
3D Control Switch
PCM - unmuted, turned up
Line -In
CD
Microphone
Mic Boost
Phone
IEC958
IEC958 Playback AC97-SPSA
PC Speaker
Aux
Capture
External Amplifier

The above two unmuted settings are all thats required for Totem to play cd's. Also, the default Gnome player, which produces no sound, does show the record title and timer as though all is working????

Cheers
Steve
 
Old 12-14-2004, 06:06 PM   #6
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Try muting this one.

External Amplifier

good luck.
 
Old 12-14-2004, 06:50 PM   #7
steve1401
Member
 
Registered: May 2003
Location: UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 15
External amp is muted, see above post, the only unmuted ones are Master and PCM which work fine for Totem?

Thanks for the tips though

Steve
 
Old 12-14-2004, 06:55 PM   #8
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Try unmuting eveything except the External amp, then from xmms, try using the digital audio extraction option.
good luck.
 
Old 12-19-2004, 07:24 PM   #9
waldo55551976
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian 3.1 (sarge)
Posts: 1

Rep: Reputation: 0
I know this is really old but maybe someone will google it and they will be helped by this.. I had the same problem.. the first time what did the trick was installing alsa through Debian.. then alsaconf found the card and it automagically worked.. after making a new kernel I wiped it all out somehow and it stopped working.. after 2 hours of trying to figure it out I finally got it:

in alsamixer or gmixer or whatever: unmute AUX and raise the volume. I have only found ONE reference to this other than my own experience and this is here:

http://www.linuxdevcenter.com/pub/a/...op.html?page=2

if you scroll down to the bit where it shows a log "Installing ALSA" and this line:

amixer set Aux 28 unmute # set value for ALSA mixer Aux (CD) channel

if there was some way to make the CD mixer control point to the AUX mixer control this would help me out, at least

hope this helps any that find this page..
 
Old 01-28-2005, 02:46 AM   #10
386sx
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
Re: no sound from audio CD, but all other sound works

Quote:
Originally posted by steve1401
Hi
Debian, kernel 2.6.9, ALSA installed and working with .ogg, .mp3, .wav etc using Intel AC'97 Audio Controller (rev 03), vaio laptop...

The audio works except when I try to platy a cd. I have just found that Totem player DOES work, but I would prefer to use xmms or xine. They both seem be playing (in xine the screen shows the funny audio wave graphic), the CD is spinning and all ALPS audio selectors are up and unmuted.

Any ideas.

Also, sorry if this post is similar to others, but none of the others (which I have found) provide a solution
I think this page might be of some help:

http://www.jennings.homelinux.net/audio_cd.html

Quote from that page:

Since Windows ME, Windows Media Player has been using the digital IDE interface to play audio CDs. Some PC manufacturers desperate to increase margin by 2 cents have taken advantage of this to start building PCs without an audio cable from the CD drive to the sound card of the PC. Linux however depends on that audio cable to play Cds. You can easily check if you are affected if you open your case. You should see a slim cable (usually grey) in addition to the wide flat IDE cable, leading from the corner of your CD drive to either your PCI sound card, or else the motherboard if you have onboard sound.

They suggest getting a proper cable, or using software that can use the IDE digital interface to play CD's. (Software such as Totem or xmms.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 12:03 PM
Sound Problems: CD works, no system/mp3/video sound tabnaka Suse/Novell 5 01-13-2006 01:33 PM
Sound works but no CD audio in FC3 10SPlayer Fedora 2 06-07-2005 12:56 AM
Sound card works but CD player doesn't make a sound? OmnipotentOscar Linux - Newbie 2 02-03-2005 04:42 AM
sound works in root - no sound in user - Debian seanb Debian 9 02-28-2004 01:42 AM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration