LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   no sound after pkg. update ubuntu 8.10 kernel 2.6.27-4-generic (http://www.linuxquestions.org/questions/linux-general-1/no-sound-after-pkg-update-ubuntu-8-10-kernel-2-6-27-4-generic-671852/)

robert n. 09-23-2008 01:49 PM

no sound after pkg. update ubuntu 8.10 kernel 2.6.27-4-generic
 
as a general rule i update my packages each time the update icon
appears on my desktop. yesterday i updated the pkgs. as i normally
would. everything worked fine until i wanted to use the sound output
to listen to some music while i read. no matter what i tried and i
tried everything i could think of. i even went back to an earlier
kernel with no luck. i ran the system rescue disk, nothing. i now
have come crawling here in hope that someone could tell me what i
may obviously have overlooked.

rob.

fuzzyworm 09-23-2008 03:35 PM

Was the sound definitely working before the update?

Are you the same user as when it worked?

Are you a member of the 'audio' group?
Code:

getent group | grep audio
If you're not listed in:
Code:

audio:x:<gid>:<list-of-usernames>
then add yourself:
Code:

sudo adduser <your-username> audio
Can you do the following:
Code:

sudo cat /dev/urandom > /dev/dsp
and get static from your speakers? (Ctrl+C to stop it)

Is the volume turned up as you? as root?
Code:

alsamixer
sudo alsamixer

Are the speakers plugged in the right socket, powered up (if necessary) and switched on? (I've missed that one before!!)

BobNutfield 09-24-2008 03:57 PM

It may or may not be relevant, but I have the issue as well, but on a completely different distro. On Slackware 12.1 with kernel 2.6.24-5 (similar to Ubuntu Hardy's 2.6.24-19) sound working just fine. I installed a testing kernel (2.6.27-rc6) and sound also stopped working, even though all of the relevant modules are loaded. If I boot back into the 2.6.24-5 kernel, sound is fine. I am continuing to investigate this to see if it is an issue with the 2.6.27 kernel.

Bob

fuzzyworm 09-25-2008 08:58 AM

That would probably imply a kernel issue - though Robert N would seem to be having more problems:

Quote:

i even went back to an earlier
kernel with no luck
Still, keep us posted if you find anything.

robert n. 09-26-2008 09:45 PM

to fuzzyworm.
sorry for the delay in replying. the sound was great before the update and i am the
only user. the answer to getent group | grep audio was audio:x:29:pulse,robert-laptop,robert.
the second command i had no clue about. robert@robert-laptop:~$ is at the start of my command line which is the reason robert-laptop came up as a user. the only other info
i can think of was there was no sound at all from the speakers either in the laptop or my external ones.

rob.

fuzzyworm 09-27-2008 09:17 AM

Code:

$ getent group | grep audio
audio:x:29:pulse,robert-laptop,robert

That looks fine.
Quote:

Originally Posted by robert n. (Post 3292999)
the second command i had no clue about.

Which one? 'adduser' was to add you to the 'audio' group, if you weren't already a member. Did you try
Code:

sudo cat /dev/urandom > /dev/dsp
What this command does is to send random data to the sound device, which should, if the sound card is properly set up, produce random static from the speakers. This should be run as root (sudo), so that it will not be affected by permission issues.

If this succeeds, then the problem is very likely to be a minor one.

Try:
Code:

$ ls -l /dev/ | grep audio
At least one device should be listed as belonging to the 'audio' group.

Quote:

Originally Posted by robert n. (Post 3292999)
robert@robert-laptop:~$ is at the start of my command line which is the reason robert-laptop came up as a user. the only other info
i can think of was there was no sound at all from the speakers either in the laptop or my external ones.

rob.

Was this after the test described above?

The 'alsamixer' and 'sudo alsamixer' commands, especially the 'sudo alsamixer', are a good check, because sometimes the volume is turned right down as root, so even if a user turns their own volume up, the root volume settings override it.

Do you have a TV card or any other multimedia cards that may interfere?

robert n. 09-27-2008 12:04 PM

the command line i had trouble with was, audio:x:<gid>:<list-of-usernames>.
also the test for static resulted in no sounds at all. if i missed anything i
have no idea what.

rob.

fuzzyworm 09-29-2008 04:48 PM

sorry, my bad, that was the result that you should have seen, rather than a command to type in.

That would suggest that it there probably is something wrong with your setup.

What is the soundcard?
Are you using GNOME or KDE (There is a new sound system integrated in KDE now, which may have had problems setting up.)?

Also, could you post the results of 'lspci'.

When you ran the 'cat /dev/urandom ...' command, did any errors appear, or was there just no noise? Did you have to press Ctrl+C to get back to the command prompt?

Did you try adjusting the volume as root, using 'sudo alsamixer'?

robert n. 09-29-2008 09:09 PM

you are not going to believe this but i have sound when using the line out
jack on my laptop but nothing out of it's speakers. i will try your other suggestions.
and see what strange effects will happen next.


rob.

fuzzyworm 10-02-2008 07:54 AM

Quote:

Originally Posted by robert n. (Post 3295567)
you are not going to believe this but i have sound when using the line out
jack on my laptop but nothing out of it's speakers. i will try your other suggestions.
and see what strange effects will happen next.


rob.


That sounds like it's just a mixer problem - quite easily resolved with alsamixer.

Load alsamixer (sudo if necessary - root sometimes has different settings that may override the standard suer settings), then use the left and right arrow keys to move to the appropriate channel for the headphone socket, then use up and down arrow keys to adjust the volume. Press 'M' to mute/unmute the channel.

Hope this helps

phorgan1 10-25-2008 01:37 PM

I have the same problem
 
No output from sudo cat /dev/urandom >/dev/dsp
using 2.6.27-7 on Ibex, no sound since upgrade. With pulseaudio, the alsamixer only shows Playback Capture and All. Everything's at 100% as root and myself. I'm in the audio group, the devices are there. lspci shows my intel sound hardware, the snd-hal-intel sound module is loaded. Using another mixer I was able to check all inputs up and not muted. Looks like ubuntuforums has a lot of threads about this, but their database seems hung this morning so I can't look at them. The only message in /var/log/message that might have anything to do with it is:

Quote:

Oct 25 10:08:03 dell kernel: [ 98.478777] canberra-gtk-pl[6996]: segfault at 9fe2dc0 ip b725684d sp b6ffcf10 error 6 in libpulse.so.0.4.1[b7217000+4e000]
and from syslog:
Quote:

Oct 25 10:08:04 dell gnome-session[6846]: WARNING: Application 'libcanberra-login-sound.desktop' failed to register before timeout
HELP!!!;)

Patrick

xloop 12-05-2008 09:25 AM

Hi all,

I had the same problem after the update. i did the following and now it works now.

add your username as stated above, if its not already there.

try running alsamixer as sudo

then make sure the playback devices are not muted.

press m to unmute.

hope this helps

Enigmacat 01-28-2009 08:46 PM

No Sound In Ubuntu 8.10
 
Quote:

Originally Posted by fuzzyworm (Post 3293404)
Code:

$ getent group | grep audio
audio:x:29:pulse,robert-laptop,robert

That looks fine.

Which one? 'adduser' was to add you to the 'audio' group, if you weren't already a member. Did you try
Code:

sudo cat /dev/urandom > /dev/dsp
What this command does is to send random data to the sound device, which should, if the sound card is properly set up, produce random static from the speakers. This should be run as root (sudo), so that it will not be affected by permission issues.

If this succeeds, then the problem is very likely to be a minor one.

Try:
Code:

$ ls -l /dev/ | grep audio
At least one device should be listed as belonging to the 'audio' group.



Was this after the test described above?

The 'alsamixer' and 'sudo alsamixer' commands, especially the 'sudo alsamixer', are a good check, because sometimes the volume is turned right down as root, so even if a user turns their own volume up, the root volume settings override it.

Do you have a TV card or any other multimedia cards that may interfere?

I followed through with each step and received a positive for all checks, I am in the user list, and when I ran the:
Code:

sudo cat /dev/urandom > /dev/dsp
I did get static from my speakers. Now how do I fix my problem. Also note that when I go to System > Preferences > Sound and do a sound play back test this is what I get:
Code:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument
What is this telling me beyond I am not getting sound?

fuzzyworm 01-29-2009 10:18 AM

It's not a problem I recognise, but these people seem to have had variable success solving it.

Hope this is of some help.

harddrive4096 03-13-2009 07:41 AM

It worked fine with 7, but 8 has a bug for sure.


All times are GMT -5. The time now is 01:16 PM.