LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 10-06-2004, 02:27 PM   #1
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
NIS prob: added user to server, but can't login to client


I added a user to my NIS server, ran the makefile to update (the db?).

If I log into a client & run "ypcat passwd" or "ypcat passwd.byname", I can see the user I added (who is named "render"), but if I "ypmatch render passwd", I get "Can't match key render in map passwd.byname. Reason: No such key in map"

I've restarted ypbind on the client. I have the "+::::::" entry in my /etc/passwd file. What step have I missed?
 
Old 10-06-2004, 03:54 PM   #2
markham82
LQ Newbie
 
Registered: Oct 2004
Location: Rochester, NY, USA
Distribution: Red Hat 7, 9, Fedora Core 2, Windows 2000/XP
Posts: 27

Rep: Reputation: 15
Have you checked your /etc/nsswitch.conf file on the client? It needs to be set up to use NIS first before it looks at the local passwd file. Open up /etc/nsswitch.conf and make sure the following portion looks like this:

Code:
..

passwd     nis files
group      nis files
shadow     nis files

..
Hope this helps

~Steve

Last edited by markham82; 10-06-2004 at 03:57 PM.
 
Old 10-06-2004, 04:58 PM   #3
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
Quote:
Originally posted by markham82
Have you checked your /etc/nsswitch.conf file on the client? It needs to be set up to use NIS first before it looks at the local passwd file. Open up /etc/nsswitch.conf and make sure the following portion looks like this:

Code:
..

passwd     nis files
group      nis files
shadow     nis files

..
Hope this helps

~Steve
The order shouldn't matter, should it? As long as "nis" is in there, if it doesn't find it in "files" or whatever comes first, it will continue until it runs out of options.

my current setup looks at files first, but it does work for other users that aren't in my passwd file but are on the NIS server.

hmmm...
 
Old 10-06-2004, 05:29 PM   #4
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
problem fixed. I needed to restart the ypserv deamon on the NIS server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup a solaris NIS client while with a Linux NIS server? ntcm Linux - Security 2 03-31-2004 01:43 PM
How to setup a solaris NIS client while with a Linux NIS server? ntcm Linux - Networking 1 03-31-2004 08:51 AM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Solaris / OpenSolaris 1 03-31-2004 07:10 AM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Linux - General 1 03-31-2004 07:10 AM
nis client login - user home dir not fnd synfield Linux - Networking 0 03-27-2003 04:51 AM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration