LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Nagios Webinterface (http://www.linuxquestions.org/questions/linux-general-1/nagios-webinterface-4175456588/)

Ashish Sood 04-02-2013 04:35 PM

Nagios Webinterface
 
Hi all ,

I had just installed NAGIOS 2.x using my yum i know i am using old version of it,but later i will upgrade it.
i am facing problem regarding web interface of nagios means when ever i click on any option in the web interface i got this permission issues message which irritating me alot because i allowed all in my nagios.conf file but sill i am getting this message

It appears as though you do not have permission to view information for any of the hosts you requested...

If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
and check the authorization options in your CGI configuration file.


below is my nagios.conf [ /etc/httpd/conf.d/nagios.conf]

ScriptAlias /nagios/cgi-bin/ /usr/lib/nagios/cgi-bin/
<Directory /usr/lib/nagios/cgi-bin/>
Options ExecCGI
order deny,allow
Allow from all
Allow from 127.0.0.1
AuthType Basic
AuthUserFile /etc/nagios/passwd
AuthName "nagios"
require valid-user
</Directory>

Alias /nagios/ /usr/share/nagios/html/
<Directory /usr/share/nagios/html/>
Options None
order deny,allow
Allow from all
Allow from 127.0.0.1
AuthType Basic
AuthUserFile /etc/nagios/passwd
AuthName "nagios"
require valid-user
</Directory>

# For SSL-servers
#<Directory /usr/lib/nagios/cgi-bin/>
# Options ExecCGI
# SSLRequireSSL
# order deny,allow
# deny from all
# allow from 127.0.0.1
# AuthType Basic
# AuthUserFile /etc/nagios/passwd
# AuthName "nagios"
# require valid-user
#</Directory>
#
#Alias /nagios/ /usr/share/nagios/html/
#<Directory /usr/share/nagios/html/>
# Options None
# SSLRequireSSL
# order deny,allow
# deny from all
# allow from 127.0.0.1
# AuthType Basic
# AuthUserFile /etc/nagios/passwd
# AuthName "nagios"
# require valid-user
#</Directory>



Please let me know where is the problem resides.

Ashish Sood 04-02-2013 04:46 PM

I just solved my own question by allowing this two parameter in cgi.cfg file

authorized_for_system_information=nagiosadmin
authorized_for_all_hosts=nagiosadmin


Thanks


All times are GMT -5. The time now is 06:51 AM.